SUNWtgnome-tsol-libs.spec
changeset 11864 d37da9c99946
child 11906 26253a7626d8
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWtgnome-tsol-libs.spec	Fri Mar 14 15:14:50 2008 +0000
@@ -0,0 +1,128 @@
+#
+# spec file for package SUNWtgnome-tsol-libs
+#
+# includes module(s): libgnometsol
+#
+# Copyright (c) 2005 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner:stephen
+
+%define libgnometsol_version 0.6
+
+%include Solaris.inc
+
+Name:                    SUNWtgnome-tsol-libs
+Summary:                 GNOME Trusted Extensions Libraries - platform dependent
+Version:                 %{default_pkg_version}
+Source:			 http://dlc.sun.com/osol/jds/downloads/extras/tjds/libgnometsol-%{libgnometsol_version}.tar.bz2
+Source1:		 l10n-configure.sh
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%if %build_tjds
+
+%include default-depend.inc
+Requires: SUNWxwts
+Requires: SUNWgnome-base-libs
+Requires: SUNWgnome-libs
+BuildRequires: SUNWxwts
+BuildRequires: SUNWgnome-base-libs-devel
+BuildRequires: SUNWgnome-libs-devel
+
+%if %build_l10n
+%package l10n
+Summary:                 %{summary} - l10n files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires: %{name}
+%endif
+
+%package devel
+Summary:                 GNOME Trusted Extensions Libraries - platform independent
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires: SUNWtgnome-tsol-libs
+
+
+%prep
+%setup -q -n libgnometsol-%{libgnometsol_version}
+%if %build_l10n
+bash -x %SOURCE1
+%endif
+
+%build
+export ACLOCAL_FLAGS="-I /usr/share/aclocal"
+
+libtoolize -f
+glib-gettextize --copy --force
+intltoolize --copy --force
+aclocal $ACLOCAL_FLAGS
+autoconf
+autoheader
+automake -acf
+
+./configure --with-gnome-prefix=%{_prefix} \
+            --prefix=%{_prefix}
+
+%install
+make install DESTDIR=$RPM_BUILD_ROOT
+rm $RPM_BUILD_ROOT%{_libdir}/libgnometsol.la
+rm $RPM_BUILD_ROOT%{_libdir}/libgnometsol.a
+%if %build_l10n
+%else
+rm -rf $RPM_BUILD_ROOT%{_datadir}
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, other)
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/libgnometsol.so*
+
+%if %build_l10n
+%files l10n
+%defattr (-, root, other)
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/locale
+%endif
+
+%files devel
+%defattr (-, root, other)
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/pkgconfig
+
+%endif
+
+%changelog
+* Fri Mar 14 2008 - [email protected]
+- update version. point source at dlc.sun.com
+
+* Fri Sep 15 2006 - [email protected]
+- Add *-10n package.
+
+* Sun Jul 30 2006 - [email protected]
+- Always use nightly tarballs as source.
+
+* Wed Jul 19 2006 - [email protected]
+- Update Build/BuildRequires after check-deps.pl run.
+
+* Tue Jul 11 2006 - [email protected]
+- Add autogen.sh commands to %prep to permit building from 'cvs co' tarballs.
+
+* Fri Jun 30 2006 - <[email protected]>
+- changed version to default for port to vermillion
+
+* Tue Feb 14 2006 - <[email protected]>
+- Added Build/BuildRequires for SUNWgnome-base-libs/-devel.
+
+* Mon Feb 13 2006 - <[email protected]>
+- Added Build/BuildRequires for SUNWxwts
+
+* Thu Aug 25 2005 - <[email protected]>
+- created