base-specs/libtheora.spec
author yippi
Wed, 07 Nov 2007 00:20:00 +0000
changeset 11132 0183b8aba79a
parent 11122 a56928b8a1ec
child 11147 620d3ae85d2e
permissions -rw-r--r--
2007-11-06 Brian Cameron <[email protected]> * SUNWgnome-terminal.spec: Add -R/usr/sfw/lib to LDFLAGS (-L/usr/sfw/lib was already there.). * base-specs/vte.spec, patches/vte-03-selection-perf-improve.diff: Removing this patch. Doing research, I found this patch is related to bugzilla bug #122656 and not #143914 as the patch comment suggested. This patch was rejected by the community. In testing, I see no performance loss when not using this patch. Also, when using this patch, it breaks when there are multiple URL's in the terminal - only the first gets highlighted ever. So I am getting rid of this old/stale patch. I think this patch used to also contain some code fixes relating to bugzilla bug #122656 that did go upstream and got factored out of the patch. * base-specs/gnome-terminal.spec: Add --disable-scrollkeeper to configure. * base-specs/speex.spec, base-specs/libtheora.spec, base-specs/libvorbis.spec, base-specs/libogg.spec: Add bugdb info. Add patch number to libtheora patch I added yesterday.

#
# spec file for package libtheora
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
# bugdb: https://trac.xiph.org/
#
Name:         libtheora
License:      Xiph
Group:        System Environment/Libraries
Version:      1.0
%define tarball_version 1.0beta2
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      The Theora Video Compression Codec.
Source:       http://downloads.xiph.org/releases/theora/%{name}-%{tarball_version}.tar.gz
#owner:yippi date:2004-11-24 type:bug bugid:1256
Patch1:       libtheora-01-fixlink.diff
URL:          http://theora.org/
URL:          http://www.theora.org/
BuildRoot:    %{_tmppath}/%{name}-%{tarball_version}-build
Docdir:       %{_docdir}/%{name}
Autoreqprov:  on

BuildRequires:  libogg-devel >= 1.1
BuildRequires:  libvorbis-devel >= 1.0.1
BuildRequires:  SDL-devel
Requires:       libvorbis >= 1.0.1

%description
Theora is Xiph.Org's first publicly released video codec, intended
for use within the Ogg's project's Ogg multimedia streaming system.
Theora is derived directly from On2's VP3 codec; Currently the two are
nearly identical, varying only in encapsulating decoder tables in the
bitstream headers, but Theora will make use of this extra freedom
in the future to improve over what is possible with VP3.

%package devel
Summary:        Development tools for Theora applications.
Group:          Development/Libraries
Requires:       %{name} = %{version}-%{release}
Requires:       libogg-devel >= 1.1
 
%description devel
The libtheora-devel package contains the header files and documentation
needed to develop applications with Ogg Theora.

%prep
%setup -q -n %{name}-%{tarball_version}
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I ./m4
autoconf
automake -a -c -f
CFLAGS="$RPM_OPT_FLAGS" \
./configure --enable-shared     \
            --prefix=%{_prefix} \
            --sysconfdir=%{_sysconfdir} \
            --mandir=%{_mandir} \
            --disable-asm

make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install

#clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*la

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc COPYING README
%{_libdir}/libtheora.so.*

%files devel
%defattr(-,root,root)
%{_datadir}/doc/*
%{_libdir}/libtheora.so
%{_includedir}/theora
%{_includedir}/theora/theora.h
%{_libdir}/pkgconfig/theora.pc

%changelog
* Mon Nov 05 2007 - [email protected]
- Bump to 1.0beta2.
* Fri Feb 09 2006 - [email protected]
- Go back to 1.0alpha7, but add --disable-asm configure flag so that
  we don't try to compile GCC-style assembler code with Sun Studio
  compiler.  Remove upstream patch 01-noversionscript.
* Wed Dec 06 2006 - [email protected]
- Revert to 1.0alpha5 because of compilation errors. Add patch too.
* Sun Dec 03 2006 - [email protected]
- Remove upstream patch, 01-noversionscript.
* Thu Nov 30 2006 - [email protected]
- Bump to 1.0alpha7.
* Thu Nov 10 2005 - [email protected]
- Change %setup to reference %{tarball_version} in order to build.
* Tue Sep 20 2005 - [email protected]
- Bump to 1.0alpha5
* Fri Sep 09 2005 - [email protected]
- Move ACLOCAL_FLAGS setting to the Solaris spec file
- libtoolize so it builds with newer libtool
* Fri Sep 02 2005 - [email protected]
- Set ACLOCAL_FLAGS to build on Solaris.
* Tue Aug 02 2005 - [email protected]
- Change copyright to license
* Tue Jul 26 2005 - [email protected]
- Add patch libtheora-1.0alpha4-01-docs-make.diff
* Wed Jul 20 2005 - [email protected]
- Initial spec file checkin