SUNWgnome-libs.spec
author laca
Wed, 25 Apr 2007 01:42:08 +0000
changeset 9780 21510eb397b1
parent 9761 3596ceacc183
child 9836 8c953a7b34c8
permissions -rw-r--r--
2007-04-24 Laszlo (Laca) Peter <[email protected]> * SUNWgksu.spec: fix default attributes * SUNWevolution-exchange.spec, SUNWevolution.spec, SUNWfirefox.spec, SUNWgnome-a11y-dasher.spec, SUNWgnome-applets.spec, SUNWgnome-archive-mgr.spec, SUNWgnome-calculator.spec, SUNWgnome-cd.spec, SUNWgnome-crash-report.spec, SUNWgnome-desktop-prefs.spec, SUNWgnome-devhelp.spec, SUNWgnome-file-mgr.spec, SUNWgnome-gtksourceview.spec, SUNWgnome-hex-editor.spec, SUNWgnome-im-client.spec, SUNWgnome-img-editor.spec, SUNWgnome-img-organizer.spec, SUNWgnome-img-viewer.spec, SUNWgnome-keyring-manager.spec, SUNWgnome-libs.spec, SUNWgnome-media-player.spec, SUNWgnome-panel.spec, SUNWgnome-pdf-viewer.spec, SUNWgnome-pilot.spec, SUNWgnome-print.spec, SUNWgnome-remote-desktop.spec, SUNWgnome-session.spec, SUNWgnome-system-tools.spec, SUNWgnome-terminal.spec, SUNWgnome-text-editor.spec, SUNWgnome-themes.spec, SUNWgnome-vfs.spec, SUNWopenjade.spec, SUNWthunderbird.spec: s/0755/-/ in defattr so that files are not made all executable * SUNWvirt-manager.spec: s/0755/-/ in defattr so that files are not made all executable and define l10n subpkg

#
# spec file for package SUNWgnome-libs
#
# includes module(s): scrollkeeper, startup-notification, libgtkhtml,
# 	              libgnome, libbonoboui, libgnomeui, libexif-gtk
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: alo
#
%include Solaris.inc
%use scrollkeeper = scrollkeeper.spec
%use startupnotification = startup-notification.spec
%use libgtkhtml = libgtkhtml.spec
%use libgnome = libgnome.spec
%use libbonoboui = libbonoboui.spec
%use gnomekeyring = gnome-keyring.spec
%use libgnomeui = libgnomeui.spec
%use libexif_gtk = libexif-gtk.spec

Name:                    SUNWgnome-libs
Summary:                 GNOME platform libraries
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs-root
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-a11y-base-libs
Requires: SUNWgnome-vfs
Requires: SUNWgnome-audio
Requires: SUNWlibexif
Requires: SUNWxwrtl
Requires: SUNWxwplt
Requires: SUNWlibms
Requires: SUNWlxml
Requires: SUNWfreetype2
Requires: SUNWlibpopt
Requires: SUNWpng
Requires: SUNWTiff
Requires: SUNWjpg
Requires: SUNWgnome-component
Requires: SUNWgnome-config
Requires: SUNWlxsl
Requires: SUNWpostrun
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-a11y-base-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-vfs-devel
BuildRequires: SUNWgnome-audio-devel
BuildRequires: SUNWlibexif-devel
BuildRequires: SUNWlibpopt-devel

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%package devel		
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-vfs-devel
Requires: SUNWgnome-audio-devel
Requires: SUNWperl584usr
Requires: SUNWlibms
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-component
Requires: SUNWlibpopt

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%scrollkeeper.prep -d %name-%version
%startupnotification.prep -d %name-%version
%libgtkhtml.prep -d %name-%version
%libgnome.prep -d %name-%version
%libbonoboui.prep -d %name-%version
%gnomekeyring.prep -d %name-%version
%libgnomeui.prep -d %name-%version
%libexif_gtk.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
PKG_CONFIG_DISABLE_UNINSTALLED=
unset PKG_CONFIG_DISABLE_UNINSTALLED
export PKG_CONFIG_PATH=../libgnome-%{libgnome.version}/libgnome:../gnome-keyring-%{gnomekeyring.version}:../libbonoboui-%{libbonoboui.version}/bonobo:%{_pkg_config_path}
export CFLAGS="%optflags -I/usr/sfw/include -DANSICPP"
export RPM_OPT_FLAGS="$CFLAGS"
export CPPFLAGS="-I/usr/sfw/include"
export LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"
%scrollkeeper.build -d %name-%version
%startupnotification.build -d %name-%version
%libgtkhtml.build -d %name-%version
%libgnome.build -d %name-%version
%libbonoboui.build -d %name-%version
%gnomekeyring.build -d %name-%version
%libgnomeui.build -d %name-%version
%libexif_gtk.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%scrollkeeper.install -d %name-%version
%startupnotification.install -d %name-%version
%libgtkhtml.install -d %name-%version
%libgnome.install -d %name-%version
%libbonoboui.install -d %name-%version
%gnomekeyring.install -d %name-%version
%libgnomeui.install -d %name-%version
%libexif_gtk.install -d %name-%version

rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

chmod 755 $RPM_BUILD_ROOT%{_mandir}/man1/*.1
chmod 755 $RPM_BUILD_ROOT%{_mandir}/man3/*.3
chmod 0644 $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/Bonobo_Sample_Controls.server
chmod 0644 $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/GNOME_Moniker_std.server

rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
rm -rf $RPM_BUILD_ROOT%{_datadir}/applications

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/scrollkeeper/Templates/[a-z]*
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'xmlcatalog --noout --add "rewriteSystem" \' ;
  echo '"http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0" \' ;
  echo '"file://%{_datadir}/xml/scrollkeeper/dtds" %{_sysconfdir}/xml/catalog'
) | $BASEDIR/lib/postrun -c JDS

( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%preun
( echo 'xmlcatalog --noout --delete "rewriteSystem" \' ;
  echo '"http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0" \' ;
  echo '"file://%{_datadir}/xml/scrollkeeper/dtds" %{_sysconfdir}/xml/catalog'
) | $BASEDIR/lib/postrun -c JDS

%postun
rm -rf $PKG_INSTALL_ROOT/var/lib/scrollkeeper

%post root
( echo 'test -x /usr/bin/gconftool-2 || {';
  echo '  echo "ERROR: gconftool-2 not found"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:/etc/gconf/gconf.xml.defaults';
  echo 'export GCONF_CONFIG_SOURCE';
  echo '/usr/bin/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/*.schemas'
) | $BASEDIR/var/lib/postrun/postrun -u -c JDS_wait

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/desktop_gnome_accessibility_keyboard.schemas';
  echo '         $SDIR/desktop_gnome_accessibility_startup.schemas';
  echo '         $SDIR/desktop_gnome_applications_at_visual.schemas';
  echo '         $SDIR/desktop_gnome_applications_at_mobility.schemas';
  echo '         $SDIR/desktop_gnome_applications_browser.schemas';
  echo '         $SDIR/desktop_gnome_applications_help_viewer.schemas';
  echo '         $SDIR/desktop_gnome_applications_terminal.schemas';
  echo '         $SDIR/desktop_gnome_applications_window_manager.schemas';
  echo '         $SDIR/desktop_gnome_background.schemas';
  echo '         $SDIR/desktop_gnome_file_views.schemas';
  echo '         $SDIR/desktop_gnome_interface.schemas';
  echo '         $SDIR/desktop_gnome_lockdown.schemas';
  echo '         $SDIR/desktop_gnome_peripherals_keyboard.schemas';
  echo '         $SDIR/desktop_gnome_peripherals_mouse.schemas';
  echo '         $SDIR/desktop_gnome_sound.schemas';
  echo '         $SDIR/desktop_gnome_thumbnailers.schemas';
  echo '         $SDIR/desktop_gnome_typing_break.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a


%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/scrollkeeper-config
%{_bindir}/scrollkeeper-get-cl
%{_bindir}/scrollkeeper-get-content-list
%{_bindir}/scrollkeeper-get-extended-content-list
%{_bindir}/scrollkeeper-get-index-from-docpath
%{_bindir}/scrollkeeper-get-toc-from-docpath
%{_bindir}/scrollkeeper-get-toc-from-id
%{_bindir}/scrollkeeper-install
%{_bindir}/scrollkeeper-preinstall
%{_bindir}/scrollkeeper-rebuilddb
%{_bindir}/scrollkeeper-uninstall
%{_bindir}/scrollkeeper-update
%{_bindir}/gnome-keyring*
%{_bindir}/gnome-open
%{_bindir}/bonobo-browser
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/bonobo/monikers/*.so
%{_libdir}/bonobo/servers/*.server
%{_libdir}/gtk-2.0/2.*.*/filesystems/lib*.so*
%{_libdir}/libglade/2.0/*.so
%{_libexecdir}/gnome_segv2
%{_libexecdir}/gnome-keyring-ask
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gnome-2.0/*
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/*
%{_datadir}/omf/scrollkeeper
%{_datadir}/scrollkeeper/doc/writing_scrollkeeper_omf_files/C
%{_datadir}/scrollkeeper/stylesheets
%{_datadir}/scrollkeeper/Templates/C
%{_datadir}/xml
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/scrollkeeper-extract
%{_bindir}/scrollkeeper-gen-seriesid
%{_bindir}/test-moniker
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/bonobo-2.0
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gtk-doc/*
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*

%files root
%attr (0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, sys)
%{_sysconfdir}/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_accessibility_startup.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_applications_at_visual.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_applications_at_mobility.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_applications_browser.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_applications_help_viewer.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_applications_terminal.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_applications_window_manager.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_background.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_file_views.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_interface.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_lockdown.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_mouse.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_sound.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_thumbnailers.schemas
%{_sysconfdir}/gconf/schemas/desktop_gnome_typing_break.schemas
%ghost %attr (0644, root, sys) %{_sysconfdir}/scrollkeeper.conf
%{_sysconfdir}/sound

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%{_datadir}/scrollkeeper/Templates/[a-z]*
%endif

%changelog
* Thu Apr 19 2007 - [email protected]
- add postrun scripts that add/delete a rewrite rule for the scrollkeeper
  dtd to /etc/xml/catalog, so that libxml2 can find it locally and not
  try to download it from the net
* Wed Jan 10 2007 - [email protected]
- Add 2 new schema files to %files and %preun root.
* Wed Dec 13 2006 - [email protected]
- Update %files (add some docs) after removal of scrollkeeper.spec patch.
* Tue Nov 28 2006 - [email protected]
- Change attr of scrollkeeper.conf file in root package to fix 6497737.
* Mon Sep 04 2006 - [email protected]
- New Manpage tarball
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Thu Jun 29 2006 - [email protected]
- Remove gtksourceview and move it in its own pkg because it also depends
  on SUNWgnome-print and SUNWgnome-print depends on this pkg.
* Tue Jun 27 2006 - [email protected]
- Move gtksourceview from SUNWgnome-text-editor to here so that it gets built 
  in gnome-python-desktop.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Fri Jun  2 2006 - [email protected]
- s/RPM_BUILD_ROOT/PKG_INSTALL_ROOT/ in %postun... eeek!
* Thu May 25 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
- fix %postun script so that it nukes the scrollkeeper data rather than
  trying to execute scrollkeeper-update, which doesn't exist after this
  pkg is uninstalled anyway
* Mon Feb 20 2006 - [email protected]
- Complete update of Build/Requires after running check-deps.pl script.
* Thu Feb 16 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff
* Wed Oct 26 2005 - [email protected]
- Delete %{_datadir}/locale when not %build_l10n. Fix %files for same.
* Mon Oct 10 2005 - [email protected]
- Add dependency on SUNWgnome-component (bonobo-activation reqd by libgnome).
* Fri Sep 09 2005 - <[email protected]>
- remove unpackaged files
* Wed Jun 15 2005 - [email protected]
- Add bonobo-browser to %files
* Tue Oct 19 2004 - [email protected]
- Remove unnecessary sym-links to avoid build err
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 09 2004 - [email protected]
- Added gnome-open.1 manpage
* Mon Aug 30 2004 - [email protected]
- Bug 5091588 : sman3/4 files should be in a separate devel package
* Tue Aug 24 2004 - [email protected]
- move l10n files to the l10n package
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Thu Aug 19 2004 [email protected]
- Bug 5089621 : removed un-need doc due to duplicat entries
* Wed Aug 18 2004  [email protected]
- Changed /usr/share/man/sman3/*.3 permission to 0755 for Solaris integration
- Changed %{_libdir}/bonobo/servers/*.server perms for Solaris integration.
* Mon Aug 16 2004  [email protected]
- Changed /usr/share/man/sman1/*.1 permission to 0755 for Solaris integration
* Mon Jul 12 2004 - [email protected]
- Unset perms for /usr/share/pixmaps.
* Sun Jul 11 2004 - [email protected]
- Set perms for /usr/share/pixmaps.
* Sat Jul 10 2004 - [email protected]
- Remove omf/scrollkeeper dir from share package. The writing_omf_files docs
  are no longer delivered.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Mon Jun 07 2004 - [email protected]
- Added libexif-gtk to package.  Added SUNWlibexif dependency.
* Wed Jun 02 2004 - [email protected]
- Added locale symbolic links
* Thu May 27 2004 - [email protected]
- added l10n subpkg
* Sun May 02 2004 - [email protected]
- remove unnecessary SUNWgnome-javahelp-convert dependency
  to avoid circular dep
* Sun Apr 04 2004 - [email protected]
- Added %{_libdir}/gtk-2.0/*/filesystems/libgnome-vfs.so to %files
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Fri Mar 12 2004 - [email protected]
- added missing stuff in libexecdir and bindir.
* Mon Mar 01 2004 - [email protected]
- add missing libglade subdir to files
* Sat Feb 28 2004 - [email protected]
- fix gconf dir permissions (a+rX)
* Wed Feb 25 2004 - [email protected]
- add "-R%{_libdir}" to LDFLAGS
* Web Feb 25 2004 - [email protected]
- moved libgnomecanvas into SUNWgnome-base-libs
* Web Feb 25 2004 - [email protected]
- moved libart_lgpl and librsvg into SUNWgnome-base-libs
* Mon Feb 23 2004 - [email protected]
- install gconf schemas at the end of the install stage.
* Fri Feb 20 2004 - [email protected]
- Removed gail. It's now in SUNWgnome-base-a11y-libs.
* Wed Feb 18 2004 - [email protected]
- Moved librsvg here from SUNWgnome-file-mgr
- add libghttp
* Mon Feb 16 2004 - [email protected]
- Fix up dependencies and files mapping