SUNWbrasero.spec
author an230044
Mon, 27 Sep 2010 11:32:21 +0000
branchopensolaris-2009-06
changeset 20102 2d19c462bb98
parent 14204 314a598986a8
permissions -rw-r--r--
6917569 CVE-2008-5824 libaudiofile contains heap-based buffer overflow in msadpcm.c Committing for Rohini because of svn issues on opensolaris2009.06 branch.

#
# spec file for package brasero
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: lin
#
#### DO NOT BUMP MODULE TO 0.8.3 AND ABOVE AS IT
#### NOT YET READY FOR SOLARIS

%include l10n.inc
%include Solaris.inc

Name:           SUNWbrasero
License:        GPL
Version:        0.8.2
Summary:        Gnome CD/DVD burner
Source:         http://ftp.gnome.org/pub/GNOME/sources/brasero/0.8/brasero-%{version}.tar.bz2
Source1:        l10n-configure.sh 
Source2:        brasero-po-sun-%{po_sun_version}.tar.bz2
URL:            http://www.gnome.org/projects/brasero
SUNW_Basedir:   %{_basedir}
SUNW_Copyright: %{name}.copyright
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
# date:2008-09-05 owner:lin type:bug bugzilla:542136,551228
Patch1:                  brasero-01-allinone.diff
# date:2008-09-05 owner:lin type:branding
Patch2:                  brasero-02-manpages.diff
# date:2008-09-15 owner:fujiwara type:feature bugster:6748382 bugzilla:552366
Patch3:                  brasero-03-g11n-im-jacket.diff
# date:2009-01-09 owner:fujiwara type:bug bugster:6787415 bugzilla:549580 state:upstream
Patch4:                  brasero-04-po.diff

%include default-depend.inc
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-media-devel
BuildRequires: SUNWgnome-media-player-devel
BuildRequires: SUNWlxml-devel
BuildRequires: SUNWdbus-devel
Requires: SUNWpostrun
Requires: SUNWdbus
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-media
Requires: SUNWgnome-media-player
Requires: SUNWlxml
Requires: SUNWgksu

%description
Brasero is a application to burn CD/DVD for the Gnome Desktop. It is designed to be as simple as possible and has some unique features to enable users to create their discs easily and quickly.

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%if %build_l10n
%package l10n
Summary: %{summary} - l10n files
%include default-depend.inc
Requires: %{name}
%endif

%prep
%setup -q -n brasero-%{version}
find . -name '*.c' -o -name '*.h' -exec dos2unix {} {} \;

%patch4 -p1
bzcat %SOURCE2 | tar xf -
cd po-sun; make; cd ..

%patch1 -p0
%patch2 -p0
%patch3 -p1

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi
export CFLAGS="%optflags"
export LDFLAGS="%_ldflags"

intltoolize --copy --force --automake
sh %SOURCE1 --enable-copyright
libtoolize --copy --force
aclocal $ACLOCAL_FLAGS
autoheader
automake -a -c -f 
autoconf

./configure --prefix=%{_prefix} --mandir=%{_mandir} \
	--libdir=%{_libdir}		\
	--libexecdir=%{_libexecdir}	\
	--sysconfdir=%{_sysconfdir}	\
 	--disable-gnome2		\
	--disable-inotify		\
	--enable-shared			\
	--disable-static		\
	--disable-scrollkeeper		\
	--disable-gtk-doc

make -j$CPUS 

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
# According to the ARC case, we don't ship the following backends.
rm -f $RPM_BUILD_ROOT%{_libdir}/brasero/plugins/libbrasero-toc2cue.so
rm -f $RPM_BUILD_ROOT%{_libdir}/brasero/plugins/libbrasero-cdrdao.so

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%clean
rm -rf $RPM_BUILD_ROOT

%post
%include icon-cache.script
%include desktop-database-install.script

%postun
test -x $BASEDIR/lib/postrun || exit 0
%include icon-cache.script
%include desktop-database-uninstall.script

%post root
%include gconf-install.script

%postun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/brasero.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%doc README AUTHORS
%doc(bzip2) ChangeLog NEWS COPYING
%dir %attr (0755, root, other) %{_datadir}/doc
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, bin) %{_libdir}/brasero
%dir %attr (0755, root, bin) %{_libdir}/brasero/plugins
%{_libdir}/brasero/plugins/*.so
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%dir %attr(0755, root, bin) %{_datadir}/brasero
%{_datadir}/brasero/*
# %dir %attr(0755, root, bin) %{_datadir}/omf
# %{_datadir}/omf/*
%dir %attr(0755, root, root) %{_datadir}/mime
%dir %attr(0755, root, root) %{_datadir}/mime/packages
%{_datadir}/mime/packages/*
%dir %attr(0755, root, other) %{_datadir}/icons
%attr(-, root, other) %{_datadir}/icons/*
# %dir %attr(0755, root, other) %{_datadir}/gnome
# %dir %attr(0755, root, bin) %{_datadir}/gnome/help
# %{_datadir}/gnome/help/*
%dir %attr (0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*

%files root
%defattr (0755, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/brasero.schemas

%if %build_l10n
%files l10n
%defattr(-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/locale
%attr(-, root, other) %{_datadir}/locale/*
%endif

%changelog
* Tue Feb 10 2009 - [email protected]
- Add dependency on SUNWgnome-media-player, CR #6755918
* Fri Jan 16 2009 - [email protected]
- Add l10n tarball.
* Fri Jan 09 2009 - [email protected]
- Add patch po.diff from community trunk.
* Wed Sep 18 2008 - [email protected]
- Bump to 0.8.2. Update copyright.
* Mon Sep 15 2008 - [email protected]
- Add brasero-03-g11n-im-jacket.diff to enable IM for jacket editor.
* Mon Aug 18 2008 - [email protected]
- Initial version