SUNWjre-config.spec
author an230044
Mon, 27 Sep 2010 11:32:21 +0000
branchopensolaris-2009-06
changeset 20102 2d19c462bb98
parent 11977 8e26baf44976
child 14746 f863cf60392d
permissions -rw-r--r--
6917569 CVE-2008-5824 libaudiofile contains heap-based buffer overflow in msadpcm.c Committing for Rohini because of svn issues on opensolaris2009.06 branch.


# spec file for package SUNWjre-config
#
# includes module(s): j2re-config
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dermot
#
%include Solaris.inc

%use j2re_int = j2re-integration.spec

%define plugin_dir %{_libdir}/firefox/plugins
%define ns_plug_ver ns7

%ifarch i386
%define myarch i386
%endif

%ifarch sparc
%define myarch sparc
%endif


Name:                    SUNWjre-config
Summary:                 Java runtime integration
Version:                 1.0
SUNW_Category: 		 JDS,system,%{jds_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
BuildRequires: SUNWfirefox
Requires: SUNWj5rt

%package plugin
Summary:                 %{summary} - plugin
SUNW_Category: 		 JDS,system,%{jds_version}
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWfirefox
Requires: SUNWj5rt

%prep
rm -rf %name-%version
mkdir %name-%version
%j2re_int.prep -d %name-%version


%install
cd %{_builddir}/%name-%version/j2re-integration

#setup mozilla plugin
#create dummy plugin
install --mode=755 -d ${RPM_BUILD_ROOT}%{_prefix}/java/jre/plugin/%{myarch}/%{ns_plug_ver}/
touch ${RPM_BUILD_ROOT}%{_prefix}/java/jre/plugin/%{myarch}/%{ns_plug_ver}/libjavaplugin_oji.so
install --mode=755 -d ${RPM_BUILD_ROOT}%{plugin_dir}
cd ${RPM_BUILD_ROOT}%{plugin_dir}
mkdir -p  ../../../java/jre/plugin/%{myarch}/%{ns_plug_ver}
touch  ../../../java/jre/plugin/%{myarch}/%{ns_plug_ver}/libjavaplugin_oji.so
ln -s ../../../java/jre/plugin/%{myarch}/%{ns_plug_ver}/libjavaplugin_oji.so .
rm  ../../../java/jre/plugin/%{myarch}/%{ns_plug_ver}/libjavaplugin_oji.so

rm -rf $RPM_BUILD_ROOT%{_prefix}/java

%clean
rm -rf $RPM_BUILD_ROOT


%files

%files plugin
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{plugin_dir}/libjavaplugin_oji.so


%changelog
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Fri Jun 09 2006 - [email protected]
- 6349214: remove files installed in java 1.4.2 dir /usr/j2se
  results in SUNWjre-config being empty - will completely remove pkg
  once ARC fasttrack is complete
- Update %install and %files as base spec file has removed multiple files.
* Thu Apr 13 2006 - [email protected]
- changed firefox libdir to "/usr/lib"
* Thu Oct 14 2004 - [email protected]
- change CATEGORY to JDS3,system
* Tue Aug 17 2004 - [email protected]
- added SUNWj5rt dependency
* Fri Aug 06 2004 - [email protected]
- Added JavaIM.directory
* Tue Jul 15 2004 - [email protected]
- mozilla's _prefix has changed to /usr/sfw

* Tue Jul 13 2004 - [email protected]
- Set perms for /usr/share/applications again.
* Mon Jul 12 2004 - [email protected]
- Unset perms for /usr/share/applications.
* Sat Jul 10 2004 - [email protected]
- Set perms for /usr/share/applications.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Tue Jun 22 2004 - [email protected]
- remove hardcoded /opt/jds
* Mon Jun 21 2004 - [email protected]
- add Java Instant Messanger .desktop files