base-specs/evolution-exchange.spec
author convert-repo
Tue, 28 Sep 2010 11:41:29 +0000
changeset 20122 34a34bffcb68
parent 18149 3c8f7dcb0ef9
child 20154 21bfc321b6da
child 20244 ca41f1b62ef9
permissions -rw-r--r--
update tags

#
# spec file for package evolution-exchange
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner jedy
#

%define OSR LFI#105446 (gnome Exec. summary):n/a

Name:         evolution-exchange
License:      GPL v2
Group:        System/Libraries/GNOME
Version:      2.30.2
Release:      1
Distribution: Java Desktop System
Vendor:       Gnome Community
Summary:      Evolution connector for Microsoft Exchange
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
%if %build_l10n
Source1:                 l10n-configure.sh
%endif
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/ximian-connector
Autoreqprov:  on
Prereq:       /sbin/ldconfig

Patch1:       evolution-exchange-01-fixxref-modules.diff

%define evolution_version 2.2
%define libgnomeui_version 2.10.0
%define libglade_version 2.5.0
%define libsoup_version 2.2.3
%define GConf_version 2.10.0
%define openldap2_version 2.2.6
%define gtk_doc_version 1.3
%define oxygen2_version 1.4

Requires:       evolution >= %{evolution_version}
Requires:       libgnomeui >= %{libgnomeui_version}
Requires:       libglade >= %{libglade_version}
Requires:       libsoup >= %{libsoup_version}
Requires:       GConf >= %{GConf_version}
Requires:       openldap2-client >= %{openldap2_version}

BuildRequires:  evolution-devel >= %{evolution_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  libglade-devel >= %{libglade_version}
BuildRequires:  libsoup-devel >= %{libsoup_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  openldap2-devel >= %{openldap2_version}
BuildRequires:  gtk-doc >= %{gtk_doc_version}

Obsoletes:	oxygen2  <= %{oxygen2_version}
Obsoletes:      ximian-connector <= 2.2.2
Provides:       ximian-connector = 2.2.2

%description
Provides a connector library for Evolution to access Microsoft Exchange.

%prep
%setup -q
%patch1 -p1

%build

%ifos linux
%define ldap_option --with-openldap=%{_prefix}
%define krb5_option --with-krb5=%{_prefix}
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
%define ldap_option --with-sunldap=%{_prefix}
%define krb5_option --with-krb5=no
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif

if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
export CFLAGS="$CFLAGS $RPM_OPT_FLAGS"

aclocal $ACLOCAL_FLAGS -I m4
#libtoolize --force
glib-gettextize --force --copy
intltoolize --force --automake

%if %build_l10n
bash -x %SOURCE1 --enable-copyright
%endif

autoheader
automake -a -f -c --gnu
autoconf

./configure	\
	--prefix=%{_prefix}		\
	--sysconfdir=%{_sysconfdir}	\
	%gtk_doc_option			\
	%ldap_option			\
	%krb5_option

make -j$CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_bindir}/*
%{_libdir}/bonobo/servers/*
%{_libdir}/evolution-data-server-1.2/camel-providers/*.so*
%{_libdir}/evolution-data-server-1.2/camel-providers/*.urls
%{_libexecdir}/evolution/2.6/*
%{_datadir}/gtk-doc/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/evolution-exchange/*
%config %{_sysconfdir}/gconf/schemas/*

%changelog
* Mon Jun 21 2010 - [email protected]
- Bump to 2.30.2
* Wed May 26 2010 - [email protected]
- Bump to 2.30.1.
* Thu Apr  8 2010 - [email protected]
- Rmove static libraries.
* Sat Apr  3 2010 - [email protected]
- Bump to 2.30.0.
* Thu Mar 11 2010 - [email protected]
- Bump to 2.29.92.
* Mon Mar  1 2010 - [email protected]
- Bump to 2.29.91.
* Mon Feb 08 2010 - [email protected]
- Bump to 2.29.90.
* Fri Jan 29 2010 - [email protected]
- Bump to 2.29.6.
* Thu Jan 14 2010 - [email protected]
- Remove 01-libdb.diff, 02-build.diff
* Thu Jan 14 2010 - [email protected]
- Bump to 2.29.5
* Tue Dec 22 2009 - [email protected]
- Bump to 2.29.4
* Mon Dec 09 2009 - [email protected]
- Bump to 2.29.3
- Add gtk_doc_option.
- Enable parallel make.
- Add 01-libdb.diff, 02-error.diff, 03-build.diff.
* Thu Oct 29 2009 - [email protected]
- Bump to 2.28.1
* Wed Sep 23 2009 - [email protected]
- Bump to 2.28.0
* Tue Aug 25 2009 - [email protected]
- Bump to 2.27.91.
* Wed Aug 12 2009 - [email protected]
- Bump to 2.27.90.
* Fri Jul 31 2009 - [email protected]
- Bump to 2.27.5.
* Tue Jul 28 2009 - [email protected]
- Remove references to patch that doesn't exist any more.
* Thu Jul 23 2009 - [email protected]
- Bump to 2.27.4.
* Thu Jun 18 2008 - [email protected]
- Bump to 2.27.3
- Add 01-build.diff
* Tue Apr 14 2008 - [email protected]
- Bump to 2.26.1
* Thu Mar 19 2008 - [email protected]
- Bump to 2.26.0
* Thu Mar 06 2008 - [email protected]
- Bump to 2.25.92
* Thu Feb 05 2008 - [email protected]
- Bump to 2.25.90
* Thu Jan 22 2008 - [email protected]
- Bump to 2.25.5
* Wed Jan 14 2008 - [email protected]
- Bump to 2.25.4
* Wed Dec 03 2008 - [email protected]
- Bump to 2.25.2
* Wec Nov 05 2008 - [email protected]
- Update license version.
* Tue Sep 22 2008 - [email protected]
- Bump to 2.24.0.
* Tue Sep 16 2008 - [email protected]
- Bump to 2.23.92.
* Tue Sep 02 2008 - [email protected]
- Bump to 2.23.91.
* Thu Aug 21 2008 - [email protected]
- Bump to 2.23.90.
* Tue Aug 05 2008 - [email protected]
- Bump to 2.23.6.
* Tue Jul 22 2008 - [email protected]
- Bump to 2.23.5.
* Tue Jun 17 2008 - [email protected]
- Bump to 2.23.4. Remove upstream patch, 01-libebackend.
* Wed Jun 03 2008 - [email protected]
- Bump to 2.23.3 and add 01-libebackend.diff.
* Wed May 28 2008 - [email protected]
- Bump to 2.23.2.
* Tue May 27 2008 - [email protected]
- Bump to 2.22.2.
* Wed May 14 2008 - [email protected]
- Bump to 2.22.1.2.
* Fri May 01 2008 - [email protected]
- Bump to 2.22.1.1.
* Mon Apr 23 2008 - [email protected]
- Bump to 2.22.1.
* Mon Mar 10 2008 - [email protected]
- Bump to 2.22.0.
* Tue Feb 26 2008 - [email protected]
- Bump to 2.21.92.
* Tue Feb 12 2008 - [email protected]
- Bump to 2.21.91.
* Tue Jan 29 2008 - [email protected]
- Bump to 2.21.90.
* Mon Jan 14 2008 - [email protected]
- Bump to 2.21.5.
* Tue Dec 18 2007 - [email protected]
- Bump to 2.21.4.
* Tue Nov 13 2007 - [email protected]
- Bump to 2.21.2.
* Tue Oct 30 2007 - [email protected]
- Bump to 2.21.1.
* Fri Oct 19 2007 - [email protected]
- Bump to 2.12.1.
* Tue Sep 18 2007 - [email protected]
- Bump to 2.12.0.
* Mon Sep 03 2007 - [email protected]
- Bump to 2.11.92.
* Mon Aug 27 2007 - [email protected]
- Bump to 2.11.91. Remove upstream patch, 01-pretty-function.
* Wed Aug 15 2007 - [email protected]
- Bump to 2.11.90.
* Wed Aug 01 2007 - [email protected]
- Bump to 2.11.6.1.
* Tue Jul 31 2007 - [email protected]
- Bump to 2.11.6.
* Wed Jul 11 2007 - [email protected]
- Add patch 01-pretty-function to fix build error 455858.
* Tue Jul 10 2007 - [email protected]
- Bump to 2.11.5.
* Tue Jun 19 2007 - [email protected]
- Bump to 2.11.4. Remove upstream patch, 01-sun-ldap.
* Tue May 15 2007 - [email protected]
- Bump to 2.11.2.
* Thu May 10 2007 - [email protected]
- Bump to 2.11.1.
* Thu Apr 12 2007 - [email protected]
- Bump to 2.10.1.
* Tue Mar 13 2007 - [email protected]
- Bump to 2.10.0.
* Tue Feb 28 2007 - [email protected]
- Bump to 2.9.92.
- Rework evolution-exchanged-01-sun-ldap.diff.
* Tue Feb 13 2007 - [email protected]
- Bump to 2.9.91.
* Mon Jan 22 2007 - [email protected]
- Bump to 2.9.6.
* Tue Jan 9 2007 - [email protected]
- Bump version to 2.9.5
* Tue Dec 19 2006 - [email protected]
- Bump version to 2.9.4
* Mon Dec 18 2006 - [email protected]
- 01-solaris-eutil.diff removed.
- 02-sun-ldap renamed to 01-sun-ldap.
* Mon Dec 18 2006 - [email protected]
- Update patch comments.
* Thu Dec 14 2006 - [email protected]
- Set sysconfdir to /etc.
* Wed Dec 13 2006 - [email protected]
- Ship schema.
- 02-sol-macros replaced by 03-sun-ldap.
* Wed Dec 13 2006 - [email protected]
- Add patch, 03-sun-ldap, to build with Solaris LDAP defines. Bugzilla 385354.
* Wed Dec 13 2006 - [email protected]
- Change patch comments.
* Thu Dec 07 2006 - [email protected]
- Add patch 02-sol-macros to use portable macros (G_GNUC_PRETTY_FUNCTION).
  Bugzilla 383064.
* Tue Dec 05 2006 - [email protected]
- Bump to 2.9.3. Remove obsolete patch, 02-evo-api-ver-hack.
* Wed Nov 29 2006 - [email protected]
- Add patch 02-evo-api-ver-hack so that the evolution 2.9 module can be found. 
  It will be removed when evolution-exchange is bumped to 2.9.
* Tue Nov 28 2006 - [email protected]
- Should be 2.8.1 on trunk.
* Mon Nov 27 2006 - [email protected]
- Bump to 2.8.2.
* Mon Oct 23 2006 - [email protected]
- Moved evolution-exchange-01-solaris-eutil.diff
from Solaris/patches
* Fri Oct 20 2006 - [email protected]
- Remove 'find' call that remove .a/.la files because none are installed.
* Mon Oct 02 2006 - [email protected]
- Bump to 2.8.1.
* Mon Sep 04 2006 - [email protected]
- Bump to 2.8.0.
* Tue Aug 08 2006 - [email protected]
- Bump to 2.7.91.
* Mon Jul 24 2006 - [email protected]
- Bump to 2.7.90.
* Sun Jul 23 2006 - [email protected]
- Bump to 2.7.4
  Remove patch evolution-exchange-01-rename.diff
* Thu Jun 02 2006 - [email protected]
- Add patch evolution-exchange-01-rename.diff 
* Tue May 30 2006 - [email protected]
- Bump to 2.6.2.
* Mon Apr 10 2006 - [email protected]
- Bump to 2.6.1.
* Tue Apr 04 2006 - [email protected]
- Remove .a/.la files in linux spec.
* Thu Mar 30 2006 - [email protected]
- Alter "remove *.a/*.la files part" to SUNWevolution-exchange.spec
* Mon Mar 13 2006 - [email protected]
- Bump to 2.6.0.
* Tue Feb 28 2006 - [email protected]
- Bump to 2.5.92.
* Tue Feb 14 2006 - [email protected]
- Bump to 2.5.91.
* Mon Jan 30 2006 - [email protected]
- Bump to 2.5.9.0.
* Thu Jan 19 2006 - [email protected]
- Bump to 2.5.5.
* Wed Jan 04 2006 - [email protected]
- Bump to 2.5.4.
* Wed Dec 21 2005 - [email protected]
- Correct Source filed.
* Mon Dec 19 2005 - [email protected]
- Bump to 2.5.3.
* Tue Nov 29 2005 - [email protected]
- Bump to 2.4.2.
* Wed Oct 12 2005 - [email protected]
- change --with-ldap to --with-sunldap.
* Mon Oct 10 2005 - [email protected]
- Bum to 2.4.1.
* Thu Sep 15 2005 - [email protected]
- Use aclocal, ..., ./configure steps, not ./autogen,
  because download tarball does not have autogen.sh.
- Add define krb5_option, disable Kerberos 5 on Solaris.
* Wed Sep 7 2005 - [email protected]
- Bump to 2.4.0.
* Fri Sep 2 2005 - [email protected]
- Use --with-openldap=no on solaris with %ldap_option because patch is not ready.
- Use ./autogen.sh to replace libtoolize aclocal automake autoconf ./configure
  steps, because we need build code that checked out from community HEAD.
* Wed Aug 24 2005 - [email protected]
- Move the ximian-connector component over to evolution-exchange
  and bump to 2.3.8
* Tue Aug 16 2005 - [email protected]
- Bump to 2.2.3.
* Thu Jul 21 2005 - [email protected]
- Turn off OpenLDAP support on Solaris as it is too old.
* Thu Jul 14 2005 - [email protected]
- Remove obsolete gnome2-macros dir from aclocal call.
* Mon Jun 27 2005 - [email protected]
- Bump to 2.2.2
* Thu Jun 17 2004 - [email protected]
- Initial spec file for ximian-connector 1.5.9