base-specs/virt-manager.spec
author convert-repo
Tue, 28 Sep 2010 11:41:29 +0000
changeset 20122 34a34bffcb68
parent 17865 b7ff02e93f66
permissions -rw-r--r--
update tags

#
# spec file for package virt-manager
#
# Copyright (c) 2006 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner gheet
# bugdb: bugzilla.redhat.com
#

%define OSR 5345:1.x

Name:         virt-manager
Summary:      Virtual Machine Manager
Version:      0.6.1
Release:      1
License:      GPL v2, FDL v1.1
Distribution: Java Desktop System
Vendor:	      RedHat
Group:        System/GUI/GNOME
Source:       http://virt-manager.et.redhat.com/download/sources/virt-manager/%{name}-%{version}.tar.gz
%if %build_l10n
Source1:                 l10n-configure.sh
%endif
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
URL:          http://virt-manager.et.redhat.com

# date:2006-12-08 owner:dermot type:bug bugster:6530450
# Remove linux specific build options
Patch1:       virt-manager-01-build-flags.diff

# date:2007-03-09 owner:dermot type:bug bugster:6530453
# Serial console font
Patch2:       virt-manager-02-serial-console.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Must be root user to run virt-manager
Patch3:       virt-manager-03-root-user.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Solaris min storage sizes differ from Linux
Patch4:       virt-manager-04-min-storage-size.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Restrict remote/QEMU connection types
Patch5:       virt-manager-05-open-connection.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# If no connections exist, show connection startup dialog
Patch6:       virt-manager-06-connection-startup.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Virtual networks not supported, hide Network & Storage tabs for host view
Patch7:       virt-manager-07-virtual-network.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Network device detection linux specific, patch to use dladm on Solaris
Patch8:       virt-manager-08-dladm-network.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Specifically set arch when creating new VM
Patch9:       virt-manager-09-create-arch.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# --help CLI python crash bug
Patch10:       virt-manager-10-options-exit.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# Disable Remove Hardware button when VM is active
Patch11:       virt-manager-11-disable-remove-hardware.diff

# date:2009-04-17 owner:mattman type:feature bugster:6831444
# When browsing for file storage, if folder specified attempt to browse there
Patch12:       virt-manager-12-storage-browse.diff

# date:2009-08-04 owner:davelam type:branding bugster:6570425
Patch13:       virt-manager-13-gnu-gettext.diff

# date:2009-09-03 owner:mattman type:bug bugster:6877275
Patch14:       virt-manager-14-disable-local-sound.diff

# date:2009-10-05 owner:mattman type:bug bugster:6886665
Patch15:       virt-manager-15-status-refresh-interval.diff

# date:2009-12-02 owner:gheet type:bug bugster:6886658
Patch16:       virt-manager-16-pv-serial-console.diff

# date:2009-12-18 owner:gheet type:branding 
Patch17:       virt-manager-17-python-version.diff

%description
Virtual Machine Manager

%prep
%setup -q -n %name-%version
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
glib-gettextize -f

intltoolize --automake -c -f
# for intltool 0.40.4
touch po/POTFILES.in

%if %build_l10n
bash -x %SOURCE1 --enable-copyright
%endif

aclocal $ACLOCAL_FLAGS -I ./m4
libtoolize --force
automake -a -c -f
autoconf
./configure   --prefix=%{_prefix}          \
              --sysconfdir=%{_sysconfdir}  \
              --libexecdir=%{_libexecdir}
make -j $CPUS


%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm $RPM_BUILD_ROOT%{_libdir}/virt-manager/*.la
rm $RPM_BUILD_ROOT%{_libdir}/virt-manager/*.a

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%{_libdir}/virt-manager
%{_libdir}/virt-manager/*
%{_datadir}/virt-manager
%{_datadir}/virt-manager/*
%{_datadir}/locale/*
%{_bindir}/virt-manager
%{_libexecdir}/virt-manager-launch

%changelog
* Fri Dec 18 2009 - [email protected]
- Added 17-python-version.diff to hardcode to python 2.4.
* Mon Oct 04 2009 - [email protected]
- Add patch 15-status-refresh-interval.diff, fix bug 688665
* Thu Sep 03 2009 - [email protected]
- Add patch 14-disable-local-sound, fix bug : 6877275
* Wed Aug 05 2009 - [email protected]
- Replaced the patch -13-gettext-package.diff with -13-gnu-gettext.diff
  to use GNU_GLIB_GETTEXT instead of GNU_GETTEXT.
* Thu Jul 30 2009 - [email protected]
- Add patch to fix build issue.
* Fri Apr 17 2009 - [email protected]
- Bump to 0.6.1
- Remove lots of patches and add lots of new ones
* Wed Apr 15 2009 - [email protected]
- Add patch 10-cdrom-disks.diff, fix doo:8188
* Wed Apr 15 2009 - [email protected]
- Add patch 09-gtk-spin-button.diff, fix doo:8183
* Tue Apr 14 2009 - [email protected]
- Add patch 08-filesize fix bug:6829936
* Wed Nov 05 2008 - [email protected]
- Add virt-manager-07-build.diff. GNU Makefile is used.
* Fri May 16 2008 - [email protected]
- Change the patch state to upstream
* Fri Mar 21 2008 - [email protected]
- Add new patches to make it run at Solaris
* Thu Aug 16 2007 - [email protected]
- Add virt-manager-03-g11n-i18n-desktop.diff to localize .desktop file.
  Fixes 6526323
* Tue May 22 2007 - [email protected]
- bump to version 0.4.0
* Mon Apr  2 2007 - [email protected]
- add missing aclocal call and force using automake 1.9
* Mon Mar 12 2007 - [email protected]
- delete .la file
* Fri Mar 09 2007 - [email protected]
- added patch 2 for Serial Console on Solaris
* Mon Mar 05 2007 - [email protected]
- Bump to ver 0.3.1
* Fri Man 02 2007 - [email protected]
- Add bug id for patch #1
* Fri Jan 12 2007 - [email protected]
- Use libtool to set PIC option
* Wed Jan 10 2007 - [email protected]
- fixes from code review:
  handle GConf schemas properly;
  use %{_libexecdir};
  move patch 01 to linux spec file
* Fri Dec 8 2006 - [email protected]
- Initial version.