SUNWlibcroco.spec
author davelam
Fri, 22 Aug 2008 10:08:04 +0000
changeset 13256 4853158a3a6d
parent 13245 fb91dd763326
child 13598 e6be6ecb4ab8
permissions -rw-r--r--
2008-08-22 Dave Lin <[email protected]> * SUNWlibcroco.spec: Fixed /usr/lib/amd64/pkgconfig attribute issue(again).

#
# spec file for package SUNWlibcroco
#
# includes module(s): libcroco
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
#
%include Solaris.inc

%ifarch amd64 sparcv9
%include arch64.inc
%use libcroco64 = libcroco.spec
%endif

%include base.inc
%use libcroco = libcroco.spec

Name:                    SUNWlibcroco
Summary:                 Cascading Style Sheet (CSS) parsing and manipulation toolkit
Version:                 %{libcroco.version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-base-libs
Requires: SUNWlxml
BuildRequires: SUNWgnome-base-libs

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%ifarch amd64 sparcv9
mkdir %name-%version/%_arch64
%libcroco.prep -d %name-%version/%_arch64
%endif

mkdir %name-%version/%base_arch
%libcroco.prep -d %name-%version/%base_arch

%build
%ifarch amd64 sparcv9
%libcroco64.build -d %name-%version/%_arch64
%endif

%libcroco.build -d %name-%version/%base_arch

%install
%ifarch amd64 sparcv9
%libcroco64.install -d %name-%version/%_arch64
rm -r $RPM_BUILD_ROOT%{_bindir}/%_arch64
%endif

%libcroco.install -d %name-%version/%base_arch

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/csslint*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%{_libdir}/%{_arch64}/lib*.so*
%endif

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/croco-*-config
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
%{_libdir}/%{_arch64}/pkgconfig/*
%endif

%changelog
* Fri Aug 22 2008 - [email protected]
- Fixed /usr/lib/amd64/pkgconfig attribute issue.
* Thu Aug 21 2008 - [email protected]
- add 64-bit build, needed for the 64-bit librsvg
* Wed May 07 2008 - [email protected]
- Remove PERL5LIB setting as it is not necessary.
* Thu Mar 27 2008 - [email protected]
- Add SUNW_Copyright.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 11 2006 - [email protected]
- Change build dependency on SUNWgnome-base-libs-share. That pkg is obsolete
  with files now in the base package.
* Thu Apr 06 2006 - [email protected]
- Move the config binary into the -devel package.
* Fri Feb 24 2006 - [email protected]
- Update Summary.
* Fri Feb 24 2006 - [email protected]
- Update Summary.
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Tue Sep 13 2005 - [email protected]
- Now use libcroco version number.
* Wed Jul 27 2005 - [email protected]
- Created.