SUNWgnome-img-editor.spec
author laca
Sat, 29 Sep 2007 04:38:49 +0000
changeset 10572 8cdee8cd9c9c
parent 9780 21510eb397b1
child 10773 bd58be2ddf17
permissions -rw-r--r--
2007-09-29 Laszlo (Laca) Peter <[email protected]> More indiana build changes * SUNWPython.spec: add option to build with FOX X libs * SUNWbrltty.spec: add option to build with FOX instead of Nevada X * SUNWdbus-bindings.spec: convert to new style multi-ISA build; delete SUNWxwrtl dep * SUNWdbus.spec: convert to new style multi-ISA build; delete SUNWxwrtl dep * SUNWfirefox.spec: delete Nevada X deps; disable developer guide dep if sun branding is not requested * SUNWgnome-a11y-dasher.spec: delete Nevada X deps; delete some unneeded env vars * SUNWgnome-a11y-libs.spec: disable java access bridge if build without java support * SUNWgnome-a11y-speech.spec: disable packaging java stuff if the --without-java option is used * SUNWgnome-applets.spec: delete Nevada X deps; make xorg-xkb dep dependent upon nevada X build * SUNWgnome-config.spec: convert to new style multi-ISA build * SUNWgnome-desktop-prefs.spec: add support to build on FOX instead of Nevada X; disable emacs support * SUNWgnome-dialog.spec: delete Nevada X dep * SUNWgnome-file-mgr.spec: delete Nevada X dep * SUNWgnome-img-editor.spec: delete Nevada X dep * SUNWgnome-img-organizer.spec: delete Nevada X dep * SUNWgnome-img-viewer.spec: delete Nevada X dep * SUNWgnome-libs.spec: delete Nevada X dep * SUNWgnome-media-mp3.spec: delete some unneeded env vars * SUNWgnome-media.spec: delete SUNWxwrtl dep * SUNWgnome-panel.spec: delete Nevada X deps; make xorg-xkb dep dependent upon nevada X build; delete some unneeded env vars * SUNWgnome-python-libs.spec: delete some unnecessary env vars * SUNWgnome-remote-desktop.spec: disable building the java client when --without-java is used; delete unneeded env variables * SUNWgnome-session.spec: delete Nevada X deps; delete some unneeded env vars * SUNWgnome-terminal.spec: delete Nevada X deps; delete some unneeded env vars * SUNWgnome-themes.spec: disable building blueprint when the --without-blueprint option is used; disable building sun-gdm-themes when --with-sun-branding is not used * SUNWgnome-utils.spec: delete Nevada X deps; delete some unneeded env vars * SUNWlibrsvg.spec: delete Nevada X dep * SUNWprint-monitor.spec: delete SUNWxwrtl dependency, twice... * base-specs/GConf.spec: convert to new style multi-ISA build * base-specs/ORBit2.spec: convert to new style multi-ISA build * base-specs/dbus-glib.spec: convert to new style multi-ISA build * base-specs/dbus-python.spec: convert to new style multi-ISA build * base-specs/dbus.spec: convert to new style multi-ISA build * base-specs/firefox.spec: do not add developer guide bookmark when sun branding is not requested * base-specs/glib2.spec: add support for building with GNU libiconv * base-specs/gnome-backgrounds.spec: do not install sun branded desktop wallpapers when sun branding is not requested * base-specs/gnome-desktop.spec: disable the jds branding patch when jds branding is not requested * base-specs/gnome-icon-theme.spec: do not install sun java icon when sun branding is not requested * base-specs/gnome-speech.spec: disable java stuff if the --without-java option is used * base-specs/libIDL.spec: convert to new style multi-ISA build * base-specs/libbonobo.spec: convert to new style multi-ISA build * base-specs/metacity.spec: disable tjds patch when tjds support is not requested * cron-script.sh: add --with-sun-branding option

#
# spec file for package SUNWgnome-img-editor
#
# includes module(s): gimp
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dkenny
#
%include Solaris.inc

%use gimp = gimp.spec

Name:                    SUNWgnome-img-editor
Summary:                 The Gimp image editor
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-python-libs
Requires: SUNWgnome-pdf-viewer
Requires: SUNWlibms
Requires: SUNWTiff
Requires: SUNWfontconfig
Requires: SUNWfreetype2
Requires: SUNWgimpprint
Requires: SUNWgnome-print
Requires: SUNWgnome-vfs
Requires: SUNWjpg
Requires: SUNWlibexif
Requires: SUNWlibrsvg
Requires: SUNWpng
Requires: SUNWzlib
Requires: SUNWpostrun
BuildRequires: SUNWTiff-devel
BuildRequires: SUNWgnome-print-devel
BuildRequires: SUNWgnome-vfs-devel
BuildRequires: SUNWjpg-devel
BuildRequires: SUNWlibexif-devel
BuildRequires: SUNWlibrsvg-devel
BuildRequires: SUNWpng-devel
BuildRequires: SUNWgnome-python-libs-devel
BuildRequires: SUNWgnome-pdf-viewer-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-python-libs-devel

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%gimp.prep -d %name-%version

%build
export PKG_CONFIG_PATH=/jds/packages/BUILD/%{name}-%{version}/gimp-%{gimp.subver}.%{gimp.microver}:%{_pkg_config_path}
export CFLAGS="%optflags -I%{_includedir} -KPIC"
export RPM_OPT_FLAGS="$CFLAGS"
export CPPFLAGS="-I/usr/sfw/include"
export LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib"

%gimp.build -d %name-%version

%install
%gimp.install -d %name-%version

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%dir %attr (0755, root, bin) %{_libdir}/gimp
%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install
%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/environ
%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/modules
%dir %attr (0755, root, bin) %{_libdir}/gimp/%gimp.subver_install/plug-ins
%{_libdir}/gimp/%gimp.subver_install/environ/*
%{_libdir}/gimp/%gimp.subver_install/modules/lib*.so*
%{_libdir}/gimp/%gimp.subver_install/plug-ins/*
%{_libdir}/gimp/%gimp.subver_install/interpreters
%{_libdir}/gimp/%gimp.subver_install/python
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/application-registry
%{_datadir}/application-registry/*
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%{_datadir}/gimp
%dir %attr (0755, root, other) %{_datadir}/mime-info
%{_datadir}/mime-info/*
%attr (-, root, other) %{_datadir}/icons

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/*
%{_datadir}/gtk-doc
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%changelog
* Fri Sep 28 2007 - [email protected]
- delete Nevada X dep
* Tue Apr 24 2007 - [email protected]
- s/0755/-/ in defattr so that files are not made all executable
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Fri Apr 28 2006 - [email protected]
- Fix %files after move to /usr/bin.
* Fri Apr 28 2006 - [email protected]
- Move into /usr/bin as standard
* Mon Feb 20 2006 - [email protected]
- Complete update of Build/Requires after running check-deps.pl script.
* Thu Feb 16 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Fri Dec 02 2005 - [email protected]
- Change SUNWpoppler dependency to SUNWgnome-pdf-viewer as poppler has moved.
* Fri Sep 30 2005 - [email protected]
- add SUNWpoppler as build requirement.
* Tue Sep 20 2005 - [email protected]
- add unpackaged files to %files
* Tue Aug 30 2005 - [email protected]
- Add Build/Requires for SUNWgnome-pygtk2.
* Fri Jan 21 2005 - [email protected]
- Change PKG_CONFIG_PATH to build gimp-help module.
* Mon Dec 13 2004 - [email protected]
- Move to /usr/sfw to implement ARC decision.
* Sun Nov 14 2004 - [email protected]
- add -KPIC to CFLAGS, because the Makefiles hardcode -fPIC :/
* Fri Nov 12 2004 - [email protected]
- move to /usr/demo/jds
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Wed Sep 01 2004 - [email protected]
- Bug 5091588 : man5 files should be in devel-share package
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Fri Aug 20 2004 - [email protected]
- Change file paths for new version of Gimp. Use variable from gimp.spec so
  future version updates will not need a change here.
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Tue May 18 2004 - [email protected]
- add sfw to LDFLAGS/CPPFLAGS (patch from Shirley)
* Fri Mar 26 2004 - [email protected]
- Created,