SUNWsigcpp.spec
author gheet
Tue, 19 Feb 2008 16:36:08 +0000
branchgnome-2-20
changeset 10799 aaeb44343873
child 10819 0fc03e1b27bb
child 11773 b0c56dfc4139
permissions -rw-r--r--
2008-02-19 Ghee Teo <[email protected]> * SUNWgtkmm.spec SUNWcairomm.spec SUNWsigcpp.spec SUNWglibmm.spec patches/gtkmm-01-ignore-defs.diff patches/gtkmm-02-demo.diff patches/gtkmm-03-demo-installation.diff patches/glibmm-01-m4-macro.diff base-specs/sigcpp.spec base-specs/glibmm.spec base-specs/cairomm.spec base-specs/gtkmm.spec: Import of gtkmm modules into GNOME 2.20 branch for Indiana.

#
# spec file for package SUNWsigcpp
#
# includes module(s): libsigc++
#
# # Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: elaine
#

%include Solaris.inc
%use sigcpp = sigcpp.spec

Name:                    SUNWsigcpp
Summary:                 Libsigc++ - a library that implements typesafe callback system for standard C++ 
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWlibC

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
rm -rf %name-%version
mkdir %name-%version
%sigcpp.prep -d %name-%version
cd %{_builddir}/%name-%version

%build
%if %cc_is_gcc
export CXXFLAGS="%{gcc_cxx_optflags}"
%else
export CFLAGS="%optflags"
export CXX="${CXX} -norunpath"
export CXXFLAGS="%cxx_optflags"
%endif
export LDFLAGS="%_ldflags"
%sigcpp.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%sigcpp.install -d %name-%version
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*a

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%{_libdir}/sigc++*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%changelog
* Fri Feb 01 2008 - [email protected]
- create, split from SFEsigcpp.spec