pygtk2.spec
author dc144907
Tue, 27 Sep 2005 11:41:19 +0000
changeset 6016 b54189f766bc
parent 5943 5a45a5c3d49e
child 6193 011617068c65
permissions -rw-r--r--
*.spec: Bump versions. Fix Source url in some files without bumping.

#
# spec file for package pygtk2
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			pygtk2
License:		LGPL	
Group:			System/Library
Version:		2.7.4
Release:		2
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Python bindings for GTK+
Source:			http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.7/pygtk-%{version}.tar.bz2	
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on

%define libglade_version 2.4.0
%define glib2_version 2.6.0
%define gtk2_version 2.6.0
%define atk_version 1.8.0
%define pango_version 1.8.0
%define python_version 2.2

Requires:		libglade >= %{libglade_version}
Requires:		gtk2 >= %{gtk2_version}
Requires:		glib2 >= %{glib2_version}
Requires:		atk >= %{atk_version}
Requires:		pango >= %{pango_version}
Requires:		python >= %{python_version}
BuildRequires: 		gtk2-devel >= %{gtk2_version}
BuildRequires:		libglade-devel >= %{libglade_version}
BuildRequires:		glib2-devel >= %{glib2_version}
BuildRequires:		atk-devel >= %{atk_version}
BuildRequires:		pango-devel >= %{pango_version}

%description
PyGTK is an extension module for python that gives you access to the GTK+
widget set.  Just about anything you can write in C with GTK+ you can write
in python with PyGTK (within reason), but with all the benefits of python.

%package libglade
Summary: A wrapper for the libglade library for use with PyGTK
Group: Development/Languages
Requires: %{name} = %{version}

%description libglade
This module contains a wrapper for the libglade library.  Libglade allows
a program to construct its user interface from an XML description, which
allows the programmer to keep the UI and program logic separate.

%package devel
Summary: files needed to build wrappers for GTK+ addon libraries
Group: Development/Languages
Requires: %{name} = %{version}

%description devel
This package contains files required to build wrappers for GTK+ addon
libraries so that they interoperate with pygtk.

%prep
%setup -q -n pygtk-%{version}

%build
CFLAGS="$RPM_OPT_FLAGS"				\
./configure 	--prefix=%{_prefix}		\
	    	--sysconfdir=%{_sysconfdir}
make

%install
make DESTDIR=$RPM_BUILD_ROOT install
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post

%postun

%files
%defattr(-, root, root)
%{_libdir}/python?.?/site-packages/pygtk.pth
%{_libdir}/python?.?/site-packages/pygtk.py*
%dir %{_libdir}/python?.?/site-packages/gtk-2.0
%dir %{_libdir}/python?.?/site-packages/gtk-2.0/gtk
%{_libdir}/python?.?/site-packages/gtk-2.0/dsextras.py
%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/__init__.py
%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/keysyms.py
%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/compat.py
%{_libdir}/python?.?/site-packages/gtk-2.0/atk.so
%{_libdir}/python?.?/site-packages/gtk-2.0/gobject.so
%{_libdir}/python?.?/site-packages/gtk-2.0/pango.so
%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/_gtk.so

%files libglade
%{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so

%files devel
%defattr(-, root, root)
%doc examples
%doc AUTHORS NEWS README MAPPING ChangeLog
%{_bindir}/
%dir %{_includedir}/pygtk-2.0
%{_includedir}/pygtk-2.0/*.h
%dir %{_includedir}/pygtk-2.0/pygtk
%{_includedir}/pygtk-2.0/pygtk/*.h
%{_libdir}/pkgconfig/
%{_libdir}/pygtk/2.0/*.py
%{_libdir}/pygtk/2.0/demos/*.py
%{_libdir}/pygtk/2.0/demos/images/
%dir %{_datadir}/pygtk
%dir %{_datadir}/pygtk/2.0
%dir %{_datadir}/pygtk/2.0/codegen
%dir %{_datadir}/pygtk/2.0/defs
%{_datadir}/pygtk/2.0/codegen/*
%{_datadir}/pygtk/2.0/defs/*.defs

%changelog -n pygtk2
* Tue Sep 27 2005 - [email protected]
- Bump to 2.7.4.

* Thu Aug 25 2005 [email protected]
- Adjusted the defattr lines to have three parameters, not four.

* Tue Aug 16 2005 - [email protected]
- Bump to 2.7.3.

* Mon Aug 04 2003 - [email protected]
- Initial Sun release