SUNWgnome-cd-burner.spec
author yippi
Wed, 21 Jan 2009 01:25:19 +0000
changeset 14945 b5ae4790780a
parent 12029 d3017ae2202e
child 15298 073d412403f0
permissions -rw-r--r--
2009-01-20 Brian Cameron <[email protected]> * SUNWgnome-panel.spec, base-specs/libnotify.spec, patches/libnotify-01-uninstalled-pc.diff: Add patch to add uninstalled pc file and update PKG_CONFIG_PATH in top-level spec so that it finds libnotify. * SUNWgnome-media-player.spec, base-specs/totem-pl-parser.spec, base-specs/totem.spec, patches/totem-05-libsocket.diff: Bump totem to 2.25.3 and totem-pl-parser.spec to 2.25.1. * patches/totem-pl-parser-01-ignore-cdda.diff, patches/totem-01-remove-unsupported-format.diff, patches/totem-04-web-plugin.diff: Rework. * patches/totem-05-avoid-plugin-coredump.diff: Remove upstream patch. * patches/totem-06-function.diff: Add new patch so totem compiles. * SUNWgnome-cd-burner.spec, base-specs/nautilus-cd-burner.spec, patches/nautilus-cd-burner-01-always-use-cdrecord-on-solaris.diff: Bump to 2.25.3, rework patch. * SUNWgnome-terminal.spec, base-specs/gnome-terminal.spec: Bump to 2.25.5 * patches/gnome-terminal-02-aa-no-xrender.diff: Remove upstream patch. * patches/gnome-terminal-02-gthread.diff: Add new patch. * base-specs/gnome-python-desktop.spec: Bump to 2.25.1 * base-specs/GConf.spec: Bump to 2.25.0. * base-specs/sound-juicer.spec: Bump to 2.25.1. * patches/sound-juicer-01-menu-entry.diff: Rework. * base-specs/file-roller.spec: Bump to 2.25.2. * base-specs/libwnck.spec: Bump to 2.25.5. * base-specs/gnome-media.spec, patches/gnome-media-04-fixcrash.diff: Bump to 2.25.1. Remove upstream patch. * base-specs/gucharmap.spec, patches/gucharmap-02-gthread.diff: Bump to 2.24.3. Add patch needed for building. * base-specs/gconf-editor.spec: Bump to 2.24.1. * base-specs/zenity.spec: Bump to 2.24.1.

#
# spec file for package SUNWgnome-cd-burner
#
# includes module(s): gnome-cd-burner
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: stephen
#
%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use cd_burner = nautilus-cd-burner.spec

Name:                    SUNWgnome-cd-burner
Summary:                 GNOME CD burner
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-file-mgr
Requires: %name-root
Requires: SUNWgnome-config
Requires: SUNWgnome-vfs
Requires: SUNWlibC
Requires: SUNWlibms
Requires: SUNWlibmsr
Requires: SUNWmlib
Requires: SUNWhal
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-file-mgr-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-vfs-devel

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
rm -rf %name-%version
mkdir %name-%version
%cd_burner.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
%if %cc_is_gcc
%else
export CXX="${CXX} -norunpath"
%endif
export CXXFLAGS="%cxx_optflags -lCrun"
export LDFLAGS="%_ldflags"

%cd_burner.build -d %name-%version

%install
%cd_burner.install -d %name-%version
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post root
%include gconf-install.script

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/nautilus-cd-burner.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/nautilus/extensions-2.0/lib*.so*
%{_libdir}/lib*.so*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/nautilus-cd-burner
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/nautilus-cd-burner.desktop
%{_datadir}/applications/nautilus-cd-burner-open-iso.desktop
%{_datadir}/gtk-doc
%attr (-, root, other) %{_datadir}/icons
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files root
%defattr (-, root, sys)
%dir %attr(0755, root, sys) %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/nautilus-cd-burner.schemas

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*

%changelog
* Tue Jan 20 2009 - [email protected]
- Fix packaging after bumping to 2.25.3.
* Fri Feb 01 2008 - [email protected]
- Remove %{_sysconfdir}/gnome-vfs-2.0/modules as they are no longer delivered.
* Fri Jan 11 2008 - [email protected]
- Move deletion of *.la to nautilus-cd-burner.spec. Update %files for new
  tarball.
* Fri Jan 11 2008 - [email protected]
- nautilus extensions go to extensions-2.0 dir. Change %files
* Thu Jan  3 2008 - [email protected]
- use gconf-install.script instead of an inline script
* Fri Dec 15 2006 - [email protected]
- Added l10n package. Fixes 6314057.
* Fri Oct 20 2006 - [email protected]
- Remove SUNWhalh BuildRequires because header files are in SUNWhea in snv_51.
* Mon Oct 16 2006 - [email protected]
- Remove the '-rf' from the 'rm *.la *.a' lines so that any changes to the
  module source will be seen as a build error and action can be taken.
* Mon Sep 18 2006 - [email protected]
- Add SUNWhalh BuildRequires.
* Fri Sep 01 2006 - [email protected]
- New Manpage tarball
* Wed Aug 16 2006 - [email protected]
- Change 'icons' line in %files to pick up files.
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Fri Aug 11 2006 - [email protected]
- Change SUNWhal-devel ref to SUNWhal as the former does not exist.
* Tue Aug 08 2006 - [email protected]
- Add BuildRequires SUNWhal/-devel after check-deps.pl run.
* Wed Thu 26 2006 - [email protected]
- Update pkging for new tarball, including removing l10n package as no files 
  installed there.
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 25 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Sun Jan 22 2006 - [email protected]
- Add nautilus-cd-burner.desktop.
* Fri Sep 30 2005 - [email protected]
- Delete empty %gconf.xml files. Remove .la files.
* Mon Jul 11 2005 - [email protected]
- update CXXFLAGS
- added devel subpkg
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 09 2004 - [email protected]
- Added nautilus-cd-burner.1 manpage
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun 23 2004 - [email protected]
- Remove 'devel' package because no files assigned to it.
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Tue May 11 2004 - [email protected]
- add SUNWgnome-file-mgr dependency
* Mon May 03 2004 - [email protected]
- fix directory permissions
* Thu Apr 15 2004 - [email protected]
- Created