SUNWgnome-dtlogin-integration.spec
author yippi
Wed, 09 Jan 2008 07:40:51 +0000
changeset 11420 c69e370ebcc4
parent 11390 5d4f02562c57
child 11718 bedfaf6c7b10
permissions -rw-r--r--
2008-01-09 Brian Cameron <[email protected]> * base-specs/gnome-session.spec, patches/gnome-session-09-findbus.diff, patches/gnome-session-10-find-dbus-daemon.diff: Add patches needed for gnome-session to launch D-Bus session bus. * SUNWgnome-dtlogin-integration.spec: Bump to 0.33. This version changes the /usr/dt/config/Xsession.jds script so it no longer launches the D-Bus session bus. * patches/glib-04-sed-i.diff: Correct patch so it works. * manpages/man1/glade-3.1, manpages/man3/libglade-2.0.3: Fix libglade.3 manpage so the SEE ALSO section refers to "glade-3" and not "glade-2". Fix glade-3.1 manpage so it's SEE ALSO section is more similar to the libglade.3 manpage.

#
# spec file for package SUNWgnome-dtlogin-integration
#
# includes module(s): dtlogin-integration
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: laca
#
%define dtlogin_config_basedir /usr
# NOTE: If the version is bumped the new tarball must be uploaded to the
#       Sun Download Center. Contact GNOME RE for assistance.
%define tarball_version 0.34

%include Solaris.inc
%if %option_with_dt
Name:                    SUNWgnome-dtlogin-integration
SourcePackage:           SUNWgnome-dtlogin-integ-src
Summary:                 dtlogin configuration files for the JDS desktop
%else
Name:                    SUNWgnome-dtstart
Summary:                 Desktop startup scripts for JDS
Source2:                 dtstart
%endif
Version:                 %{default_pkg_version}
Source:                  http://dlc.sun.com/osol/jds/downloads/extras/dtlogin-integration-%{tarball_version}.tar.bz2
Source1:                 l10n-configure.sh
Patch1:                  SUNWgnome-dtlogin-integration-01-no-mo.diff
SUNW_BaseDir:            %{dtlogin_config_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires: SUNWgnome-panel
Requires: SUNWgnome-session
Requires: SUNWgnome-wm
%if %option_with_gnu_iconv
BuildRequires: SUNWgnu-libiconv
%else
BuildRequires: SUNWciu8
BuildRequires: SUNWhiu8
BuildRequires: SUNWiniu8
BuildRequires: SUNWjiu8
BuildRequires: SUNWkiu8
BuildRequires: SUNWtiu8
BuildRequires: SUNWuiu8
BuildRequires: SUNWloc
BuildRequires: SUNWisolc
BuildRequires: SUNWceuos
BuildRequires: SUNWcleu
BuildRequires: SUNWcleu2
BuildRequires: SUNWdeiso1
BuildRequires: SUNWeeuos
BuildRequires: SUNWesiso1
BuildRequires: SUNWeu8os
BuildRequires: SUNWfriso1
BuildRequires: SUNWhkleu
BuildRequires: SUNWhleu
BuildRequires: SUNWinleu
BuildRequires: SUNWitiso1
BuildRequires: SUNWjfpu
BuildRequires: SUNWkleu
BuildRequires: SUNWmeaos
BuildRequires: SUNWnafos
BuildRequires: SUNWnamos
BuildRequires: SUNWneuos
BuildRequires: SUNWsamos
BuildRequires: SUNWseuos
BuildRequires: SUNWsviso1
BuildRequires: SUNWtleu
BuildRequires: SUNWweuos
%endif

%prep
%setup -q -n dtlogin-integration-%{tarball_version}
%patch1 -p1

bash -x %SOURCE1

%build
export LDFLAGS="%_ldflags"
export CFLAGS="%optflags"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
libtoolize -f
intltoolize --force --copy --automake
aclocal $ACLOCAL_FLAGS
autoconf
automake -acf

./configure --with-gnome-prefix=%{_prefix} \
            --prefix=%{dtlogin_config_basedir}

%install
rm -rf $RPM_BUILD_ROOT
%if %option_with_gnu_iconv
make install DESTDIR=$RPM_BUILD_ROOT ICONV=/usr/gnu/bin/iconv ENCODING=UTF-8
%else
make install DESTDIR=$RPM_BUILD_ROOT
%endif

%if %option_without_dt
install --mode=0755 -d $RPM_BUILD_ROOT/usr/bin
install --mode=0755 %SOURCE2 $RPM_BUILD_ROOT/usr/bin/dtstart
rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/appconfig
rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/C
rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/[a-z][a-z]*
rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/Xsession*
rm -r $RPM_BUILD_ROOT%{_datadir}
%endif

rm -rf $RPM_BUILD_ROOT/tmp

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%{dtlogin_config_basedir}/dt
%if %option_with_dt
%else
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/dtstart
%endif

%changelog
* Wed Jan 09 2008 - [email protected]
- Bump to 0.34.
* Fri Dec 07 2007 - [email protected]
- Bump to 0.33.
* Thu Oct 25 2007 - [email protected]
- Add SUNWgnome-dtlogin-integration-01-no-mo.diff.
  We don't need .mo files for this package.
* Fri Sep 28 2007 - [email protected]
- combine SUNWgnome-dtlogin-integration and SUNWgnome-dtstart in one
  spec.  If this spec file is built without /usr/dt support then
  it builds SUNWgnome-dtstart with include /usr/bin/dtstart and the
  JDS startup scripts in /usr/dt/config.  /ust/bin/dtstart is a
  simple replacement for /usr/dt/bin/Xsession
* Fri Sep 07 2007 - [email protected]
- Bump to 0.32, remove upstream patch.
* Thu Aug 30 2007 - [email protected]
- Add intltoolize call to update intltool scripts.
* Mon Jul 23 2007 - [email protected]
- Added SUNWgnome-dtlogin-integration-01-g11n-xinitrc.diff. 
  Fixes 6555226, 6583891
* Tue Jun  5 2007 - [email protected]
- bump to 0.31, delete patch
* Mon Apr 02 2007 - [email protected]
- Added SUNWgnome-dtlogin-integration-01-unset-locale.diff. Fixes 6532300
* Tue Nov 14 2006 - [email protected]
- Bump to 0.29, to change menu string to 2.16. Fixes 6493544.
* Thu Aug 24 2006 - [email protected]
- remove autoheader call since there is AC_CONFIG_HEADER in configure.in
* Fri Aug 04 2006 - [email protected]
- Bump to 0.27, to change menu string to 2.15.
* Fri Jun 23 2006 - [email protected]
- bump to 0.26, fixes 6340366 "A modified version of
  /usr/dt/config/Xinitrc.jds in /etc/dt/config is not used" and
  moves the code starting ssh-agent here from gdm so that it runs
  for dtlogin users too.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu Apr  6 2006 - [email protected]
- Now use tarball_version
* Wed Feb  1 2006 - [email protected]
- Bump to 0.25 to change menu string to "Gnome 2.14 for OpenSolaris"
* Tue Sep 13 2005 - [email protected]
- remove unpackaged files
* Fri Jul  8 2005 - [email protected]
- Add definition for ACLOCAL_FLAGS in order to build.
* Fri Apr  1 2005 - [email protected]
- Update to 0.23.  Remove /usr/openwin/bin from PATH and move it to GDM2
  so it doesn't get set twice when logging in via CDE login.
* Wed Mar 16 2005 - [email protected]
- commented out the rm datadir/locale/*/LC_MESSAGES/dtlogin-integration.mo
  line since it got accidently uncommented in my last putback.
* Tue Mar 01 2005 - [email protected]
- Update to 0.22: Remove /usr/dt/bin from default user PATH.
* Wed Dec 15 2004 - [email protected]
- Update to 0.21: get rid of the login popup
* Mon Dec 13 2004 - [email protected]
- Update to 0.20. Implement ARC decision: Remove /usr/demo/jds/bin from PATH 
  and change wording for message about adding /usr/sfw/bin to the PATH 
  (Xinitrc.in).
* Fri Nov 26 2004 - [email protected]
- Added translations for new popup dialog. Asian to be modfied still.
* Fri Nov 26 2004 - [email protected]
- update to 0.17: fixes 6182467 (adds sfw login dialog)
- add %_datadir to files
* Fri Oct 29 2004 - [email protected]
- uprev to 0.16: adds comment about /usr/sfw/bin to Xinitrc, uses new
  Solaris 10 branding
* Wed Oct 20 2004 - [email protected]
- uprev to 0.15 (removes /usr/sfw/bin from the PATH)
* Fri Oct 15 2004 - [email protected]
- Uprevved tarball to 0.14 (0.12 & 0.13 already present)
* Thu Sep 09 2004 - [email protected]
- Uprevved tarball to 0.11
* Tue Sep 07 2004 - [email protected]
- Added SourcePackage tag because SUNWgnome-dtlogin-integration-src is too
  long...
* Tue Sep 07 2004 - [email protected]
- Added BuildRequires for effective iconv convertions.
* Tue Sep 07 2004 - [email protected]
- Uprevved tarball to 0.10
* Mon Sep 06 2004 - [email protected]
- Upstreamed dtlogin-integration-01-g11n-i18n-ui.diff
* Fri Sep 03 2004 - [email protected]
- Added dtlogin-integration-01-g11n-i18n-ui.diff
- Updated BuildRequires
* Mon Aug 30 2004 - [email protected]
- Uprevved tarball to 0.9 to fix bugid 5093158
* Thu Jul 08 2004 - [email protected]
- Update to version 0.7 to add /usr/sfw/bin to PATH and /usr/lib/jds-private to
  LD_LIBRARY_PATH.
* Tue Jun 22 2004 - [email protected]
- update to version 0.6 to fix th_TH attrib issue (again!)
* Mon Jun 21 2004 - [email protected]
- update to version 0.5
* Tue Jun 15 2004 - [email protected]
- update to version 0.4
- removed dtlogin-integration-01-th_TH_file_conflict.diff and
  include the same fix to the module.
* Thu Jun 10 2004 - [email protected]
- Patch dtlogin-integration-01-th_TH_file_conflict.diff to fix th_TH conflict
* Tue May 18 2004 - [email protected]
- update to version 0.3
* Tue May 18 2004 - [email protected]
- update to version 0.2
* Tue May 04 2004 - [email protected]
- initial version of the spec file