base-specs/gnome-nettool.spec
author gman
Thu, 30 Sep 2010 21:37:28 +0000
branchgnome-2-30
changeset 20130 c7dfc176dcbd
parent 17864 337913e88a9d
permissions -rw-r--r--
2010-10-01 Glynn Foster <[email protected]> * specs/SUNWos-welcome.spec: Bump to 1.0.6

#
# spec file for package gnome-nettool
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner gheet
#

%define OSR LFI#105446 (gnome Exec. summary):n/a

%include l10n.inc
Name:               gnome-nettool
Vendor:             Gnome Community
License:	    GPL/LGPL
Group:		    System/GUI/GNOME
Version:            2.30.0
Release:	    1
Summary:	    GNOME Network Tools
Source:		    http://ftp.gnome.org/pub/GNOME/sources/gnome-nettool/2.30/gnome-nettool-%{version}.tar.bz2
#owner:gheet date:2008-09-10 type:feature bugster:6736233
Patch1:             %{name}-01-sun-patch.diff
SUNW_BaseDir:       %{_basedir}
BuildRoot:          %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires:           SUNWgnome-libs

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:		 %{_basedir}
%include default-depend.inc
Requires:	 %{name}
%endif

%prep
rm -rf %name-%version
mkdir -p %name-%version
%setup -q 
%patch1 -p1

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi

export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export CFLAGS="%optflags -I/usr/include"
export RPM_OPT_FLAGS="$CFLAGS"

libtoolize --force --copy
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
#automake --add-missing
autoconf
CFLAGS="$RPM_OPT_FLAGS"
./configure \
    --prefix=%{_prefix} \
    --datadir=%{_datadir}
make -j $CPUS


%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

%if %build_l10n
%else
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif


%if %{!?_without_gtk_doc:0}%{?_without_gtk_doc:1}
rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
%endif


%clean
#rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%dir %attr (0755, root, other) %{_datadir}/icons
%{_datadir}/icons/*
%dir %attr (0755, root, other) %{_datadir}/%{name}
%{_datadir}/%{name}/*
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/*
%dir %attr (0755, root, other) %{_datadir}/omf
%{_datadir}/omf/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Wed Sep 23 2009 - [email protected]
- Bump to 2.28.0
* Mon Jun 15 2009 - [email protected]
- Bump to 2.26.2
* Wed Apr 15 2009 - [email protected]
- Bump to 2.26.1
* Mon Sep 29 2008 - [email protected]
- Bump to 2.22.1.
* Wed Sep 10 2008 - [email protected]
- Update 01-sun-patch.diff to enable ping hostname.
* Mon Aug 04 2008 - [email protected]
- Initial spec