closed/SUNWapoc.spec
author davelam
Sat, 18 Apr 2009 12:26:03 +0000
changeset 15650 dbcf7e3715dd
parent 12074 9b55b0eb183a
child 17480 1e8e4832e135
permissions -rwxr-xr-x
2009-04-18 Dave Lin <[email protected]> Update dependencies for the following spec files: o move the dependencies to the split gnome-base-libs o add other missed dependencies

#
# Copyright (c) 2004 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# This spec file generates all packages necessary for the JDS APOC
# (A Point Of Control) functionality
#
# Please find the project page at: http://so-doc.germany.sun.com/Projects/Apoc
#
# DO NOT REMOVE NEXT LINE
# PACKAGE NOT ARC REVIEWED BY SUN JDS TEAM

#==============================================================================
#  Package Information/Description Section
#
#==============================================================================

%include Solaris.inc

%use aspec = apoc.spec

%ifarch sparc
%define PLATFORM unxsols4
%else
%define PLATFORM unxsoli4
%endif

Name:           SUNWapoc
Version:        1.2
Distribution:   Sun Java(tm) Desktop System
Vendor:         Sun Microsystems, Inc.
License:        Sun Microsystems Binary Code License (BCL)
URL:            http://www.sun.com/software/javadesktopsystem/
SUNW_ProdName:  Sun Java(tm) Desktop System, Release 3
SUNW_ProdVers:  2
SUNW_Category:  APOC,application,%{jds_version}
SUNW_Copyright: %{name}.copyright

BuildRoot:      %{_builddir}/apoc/%{PLATFORM}/class/packages_build_root
Source:         apoc-%{version}%{aspec.t_suffix}.tar.bz2

Group:          Applications/Internet
Summary:        Sun Java(tm) Desktop System Configuration Agent
Requires:       SUNWlxmlr
Requires:       SUNWlxml
Requires:       SUNWgss
Requires:       SUNWapbas
Requires:       SUNWapmsc
Requires:       SUNWcsl
Requires:       SUNWcslr
Requires:       SUNWcsr
Requires:       SUNWlibms
Requires:       SUNWlibmsr
BuildRequires:  SUNWlxml-devel
SUNW_BaseDir:   /usr

%description 
Sun Java(tm) Desktop System Configuration Agent

#------------------------------------------------------------------------------

%package -n SUNWapbas
Group:          Applications/Internet
Summary:        Sun Java(tm) Desktop System Configuration Shared Libraries
Requires:       SUNWj5rt
SUNW_BaseDir:   /usr

%description -n SUNWapbas
Sun Java(tm) Desktop System Configuration Shared Libraries

#------------------------------------------------------------------------------

%package -n SUNWapmsc
Group:          Applications/Internet 
Summary:        Sun Java(tm) Desktop System Configuration Agent Miscellaneous Files
Requires:       SUNWcar
Requires:       SUNWkvm
Requires:       SUNWcsr
Requires:       SUNWcsu
Requires:       SUNWcsd
SUNW_BaseDir:   /

%description -n SUNWapmsc
Sun Java(tm) Desktop System Configuration Agent Miscellaneous Files

#------------------------------------------------------------------------------

%package -n SUNWapmcg
Group:          Applications/Internet 
Summary:        Sun Desktop Manager Configuration Files
SUNW_BaseDir:   /

%description -n SUNWapmcg
Sun Desktop Manager Configuration Files

#------------------------------------------------------------------------------

%package -n SUNWapcj
Group:          Applications/Internet 
Summary:        Sun Java(tm) Desktop System Configuration Adapter for Java Preferences 
Requires:       SUNWapoc
Requires:       SUNWcsr
Requires:       SUNWcsl
Requires:       SUNWcslr
Requires:       SUNWlibms
Requires:       SUNWlibmsr
SUNW_BaseDir:   /usr 

%description -n SUNWapcj
Sun Java(tm) Desktop System Configuration Adapter for Java Preferences 

#------------------------------------------------------------------------------

%package -n SUNWapdc
Group:          Applications/Internet 
Summary:        Sun Java(tm) Desktop System Configuration Agent Wizard
Requires:       SUNWapoc
Requires:       SUNWcsr
SUNW_BaseDir:   /usr 

%description -n SUNWapdc
Sun Java(tm) Desktop System Configuration Agent Wizard

#------------------------------------------------------------------------------

%package -n SUNWapdc-root
Group:          Applications/Internet 
Summary:        Sun Java(tm) Desktop System launch menu integration for Configuration Agent Wizard
Requires:       SUNWapdc
SUNW_BaseDir:   / 

%description -n SUNWapdc-root
Sun Java(tm) Desktop System launch menu integration for Configuration 
Agent Wizard 

#------------------------------------------------------------------------------

%package -n SUNWapcli
Group:          Applications/Internet 
Summary:        Sun Desktop Manager Command Line Interface
Requires:       SUNWapbas
Requires:       SUNWcsr
SUNW_BaseDir:   /usr

%description -n SUNWapcli
Sun Desktop Manager Command Line Interface

#------------------------------------------------------------------------------

%package -n SUNWapm
Group:          Applications/Internet 
Summary:        Sun Desktop Manager, Release 1.0
Requires:       SUNWmcon    
Requires:       SUNWapbas
Requires:       SUNWapmcg
Requires:       SUNWcsr
SUNW_BaseDir:   /usr

%description -n SUNWapm
Sun Desktop Manager, Release 1.0

#------------------------------------------------------------------------------

%package -n SUNWapmca
Group:          Applications/Internet 
Summary:        Sun Desktop Manager templates for Configuration Agent
Requires:       SUNWapm
SUNW_BaseDir:   /usr

%description -n SUNWapmca
Sun Desktop Manager templates for Configuration Agent

#------------------------------------------------------------------------------
%package -n SUNWapmso
Group:          Applications/Internet 
Summary:        Sun Desktop Manager templates for StarOffice 7
Requires:       SUNWapm
SUNW_BaseDir:   /usr

%description -n SUNWapmso
Sun Desktop Manager templates for StarOffice 7

#------------------------------------------------------------------------------

%package -n SUNWapms8
Group:          Applications/Internet 
Summary:        Sun Desktop Manager templates for StarOffice 8
Requires:       SUNWapm
SUNW_BaseDir:   /usr

%description -n SUNWapms8
Sun Desktop Manager templates for StarOffice 8

#------------------------------------------------------------------------------

%package -n SUNWapg26
Group:          Applications/Internet 
Summary:        Sun Desktop Manager templates for Gnome 2.6
Requires:       SUNWapm
SUNW_BaseDir:   /usr

%description -n SUNWapg26
Sun Desktop Manager templates for Gnome 2.6

#==============================================================================
#  Package Build Section
#
#==============================================================================

%prep
%setup -n apoc

%build
export JAVA_HOME=/usr/jdk/instances/jdk1.5.0
export PATH=${JAVA_HOME}/bin:$PATH
unset DISPLAY
make PLATFORM=%{PLATFORM} all

%install

cp %{_builddir}/apoc/packages/apoc_manager_tar/Solaris/setup ${RPM_BUILD_ROOT}/usr/share/webconsole/apoc/setup

#==============================================================================
#  Package Post(Un) Install Section
#
#==============================================================================

%preun
if [ -z "${PKG_INSTALL_ROOT}" ] ; then
 $PKG_INSTALL_ROOT/usr/lib/apoc/apocd disable
fi
exit 0

#------------------------------------------------------------------------------

%post -n SUNWapmsc
if [ -z "${PKG_INSTALL_ROOT}" ] ; then
 if [ -f /lib/svc/share/smf_include.sh ] ; then
  . /lib/svc/share/smf_include.sh
  smf_present
  if [ $? -eq 0 ] ; then
   svccfg delete -f svc:/network/apocd/udp:default > /dev/null 2>&1
   /usr/sbin/svccfg import /var/svc/manifest/network/apocd.xml
  fi
 fi
fi
exit 0

%postun -n SUNWapmsc
if [ -z "${PKG_INSTALL_ROOT}" ] ; then
 if [ -f /lib/svc/share/smf_include.sh ] ; then
  . /lib/svc/share/smf_include.sh
  smf_present
  if [ $? -eq 0 ] ; then
   /usr/sbin/svccfg export svc:/network/apocd/udp > /dev/null 2>&1
   if [ $? -eq 0 ] ; then
    /usr/sbin/svccfg delete -f svc:/network/apocd/udp
   fi
  fi
 fi
fi
exit 0

#==============================================================================
#  Package Files Section
#
#==============================================================================

%files
%defattr(0644, root, bin)
%dir %attr(0755, root, bin) /usr/lib
%dir %attr(0755, root, bin) /usr/lib/apoc
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, sys) /usr/share/lib
%dir %attr(0755, root, bin) /usr/share/lib/apoc

/usr/share/lib/apoc/apocd.jar
/usr/share/lib/apoc/db.jar

%attr(0744, root, bin) /usr/lib/apoc/apocd
%attr(0755, root, bin) /usr/lib/apoc/libFileAccess.so
%attr(0755, root, bin) /usr/lib/apoc/libdb.so.1
%attr(0755, root, bin) /usr/lib/apoc/libdb_java-4.2.so

%attr(0755, root, bin) /usr/lib/libapoc.so.1
/usr/lib/libapoc.so

#------------------------------------------------------------------------------

%files -n SUNWapbas
%defattr(0644, root, bin)
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, sys) /usr/share/lib
%dir %attr(0755, root, bin) /usr/share/lib/apoc
/usr/share/lib/apoc/policymgr.jar
/usr/share/lib/apoc/spi.jar
/usr/share/lib/apoc/ldapjdk.jar

#------------------------------------------------------------------------------

%files -n SUNWapmsc
%defattr(0644, root, sys)
%dir %attr(0755, root, sys) /etc
%dir %attr(0755, root, sys) /etc/apoc
%dir %attr(0755, root, sys) /var
%dir %attr(0755, root, sys) /var/svc
%dir %attr(0755, root, sys) /var/svc/manifest
%dir %attr(0755, root, sys) /var/svc/manifest/network
/etc/apoc/apocd.properties
/etc/apoc/os.properties
%attr(0600, root, sys) /etc/apoc/policymgr.properties
%attr(0444, root, sys) /var/svc/manifest/network/apocd.xml

#------------------------------------------------------------------------------

%files -n SUNWapmcg
%dir %attr(0755, root, sys) /etc
%dir %attr(0755, root, sys) /etc/opt
%defattr (0744, noaccess, noaccess)
/etc/opt/SUNWapmcg

#------------------------------------------------------------------------------

%files -n SUNWapcj
%defattr(-, root, bin)
%dir %attr(0755, root, bin) /usr/lib
%dir %attr(0755, root, bin) /usr/lib/apoc
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, sys) /usr/share/lib
%dir %attr(0755, root, bin) /usr/share/lib/apoc

/usr/share/lib/apoc/apocprefs.jar
/usr/lib/apoc/libapoc_java.so
%attr(0755, root, bin) /usr/lib/apoc/apocjlaunch

#------------------------------------------------------------------------------

%files -n SUNWapdc
%defattr(0755, root, bin)
%dir %attr(0755, root, bin) /usr/bin
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, sys) /usr/share/lib
%dir %attr(0755, root, bin) /usr/share/lib/apoc
%attr(0755, root, bin) /usr/bin/apoc-config
/usr/share/lib/apoc/ConfigurationWizard.class
/usr/share/lib/apoc/com

#------------------------------------------------------------------------------

%files -n SUNWapdc-root
%dir %attr(0755, root, sys) /etc
%dir %attr(0755, root, sys) /etc/X11
%dir %attr(0755, root, sys) /etc/X11/sysconfig
%attr(0644, root, sys) /etc/X11/sysconfig/apoc.desktop

#------------------------------------------------------------------------------

%files -n SUNWapcli
%defattr (0555, root, root)
%dir %attr(0755, root, bin) /usr/bin
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, sys) /usr/share/lib
%dir %attr(0755, root, bin) /usr/share/lib/apoc
%dir %attr(0755, root, bin) /usr/share/man
%dir %attr(0755, root, bin) /usr/share/man/man1
%attr(0755, root, root) /usr/bin/pgtool
%attr(0644, root, root) /usr/share/lib/apoc/apoc_cli.jar
%attr(0444, root, root) /usr/share/man/man1/pgtool.1

#------------------------------------------------------------------------------

%files -n SUNWapm
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, bin) /usr/share/webconsole
%defattr (0744, noaccess, noaccess)
%dir /usr/share/webconsole/apoc
%dir /usr/share/webconsole/apoc/packages
%{?nightly:/usr/share/webconsole/apoc/com_sun_web_ui}
/usr/share/webconsole/apoc/setup
/usr/share/webconsole/apoc/html
/usr/share/webconsole/apoc/deploy
/usr/share/webconsole/apoc/js
/usr/share/webconsole/apoc/images
/usr/share/webconsole/apoc/jsp
/usr/share/webconsole/apoc/WEB-INF
/usr/share/webconsole/apoc/dtd

#------------------------------------------------------------------------------

%files -n SUNWapmca
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, bin) /usr/share/webconsole
%defattr (0744, noaccess, noaccess)
%dir /usr/share/webconsole/apoc
%dir /usr/share/webconsole/apoc/packages
/usr/share/webconsole/apoc/packages/ConfigurationAgent_pkg

#------------------------------------------------------------------------------

%files -n SUNWapmso
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, bin) /usr/share/webconsole
%defattr (0744, noaccess, noaccess)
%dir /usr/share/webconsole/apoc
%dir /usr/share/webconsole/apoc/packages
/usr/share/webconsole/apoc/packages/StarOffice7_pkg

#------------------------------------------------------------------------------

%files -n SUNWapms8
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, bin) /usr/share/webconsole
%defattr (0744, noaccess, noaccess)
%dir /usr/share/webconsole/apoc
%dir /usr/share/webconsole/apoc/packages
/usr/share/webconsole/apoc/packages/StarOffice8_pkg

#------------------------------------------------------------------------------

%files -n SUNWapg26
%dir %attr(0755, root, sys) /usr/share
%dir %attr(0755, root, bin) /usr/share/webconsole
%defattr (0744, noaccess, noaccess)
%dir /usr/share/webconsole/apoc
%dir /usr/share/webconsole/apoc/packages 
/usr/share/webconsole/apoc/packages/Gnome2.6_pkg

#==============================================================================
#  Package Change Log Section
#
#==============================================================================

%changelog
* Mon Sep 10 2007 - [email protected]
- Only include com_sun_web_ui dir in nightly builds.
* Fri Oct 20 2006 - [email protected]
- Change JAVA_HOME again (/usr/jdk/instances/jdk1.5.0) because default in
  svn_50 (/usr/java symlink) is Java 6 and this does not have tools.jar that
  the build requires.
* Tue Aug 29 2006 - [email protected]
- Correct JAVA_HOME (/usr/j2se -> /usr/java).
* Tue Aug 29 2006 - [email protected]
- Unset DISPLAY to stop APOC installer build trying to connect to a display.
* Thu Jul  6 2006 - [email protected]
- Add BuildRequires SUNWlxml-devel to use libxml/parser.h.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Wed Mar 15 2006 - [email protected]
- Add to Build/Requires after running check-deps.pl.
* Wed Mar 01 2006 - [email protected]
- #6391879 1.1 SUNWapmsc doesn't correctly delete apoc smf service
* Fri Feb 24 2006 - [email protected]
- incorrect dependency for libm.so.2.
* Thu Feb 23 2006 - [email protected]
- Modified descriptions and summaries for Desktop Manager
- Put back the delivery of the setup script with the Manager
* Fri Feb 17 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Fri Feb 10 2006 - [email protected]
- Change version from 2.0 to 1.2
* Mon Feb 06 2006 - [email protected]
- Merged in version of file from APOC20_DEV branch
* Wed Feb 01 2006 - [email protected]
- Correcting dependencies
* Thu Dec 15 2005 - [email protected]
- Removed the LdapLoginModule.jar file from the SUNWapm package
* Fri Sep 09 2005 - [email protected]
- Add man page to apoc-cli package
* Thu Aug 18 2005 - [email protected]
- Move daemon startup to boot sequence
* Wed Oct 27 2004 - [email protected]
- removed the SUNWapcmc package and updated package summaries
* Thu Oct 14 2004 - [email protected]
- switch to bdb4
* Wed Sep 29 2004 - [email protected]
- app.xml moved to WEB-INF
* Tue Sep 28 2004 - [email protected]
- Adding removal cas for services class
* Mon Sep 27 2004 - [email protected]
- Merged the content of all other APOC spec files into this single spec file
* Mon Sep 20 2004 - [email protected]
- new tarballs for build 19
* Mon Sep 20 2004 - [email protected]
- fixing preremove for Jumpstart
* Tue Sep 06 2004 - [email protected]
- services entry now added using class action script in SUNWapmsc
* Mon Sep 06 2004 - [email protected]
- new tarballs for build 18
* Wed Sep 01 2004 - [email protected]
- new tarballs for build 17b
* Fri Aug 20 2004 - [email protected]
- Ensuring greenline stuff doesn't go in beta
* Fri Aug 13 2004 - [email protected]
- Correcting version
* Thu Aug 12 2004 - [email protected]
- reintroducing greenline support
* Fri Jul 30 2004 - [email protected]
- don't want to include greenline integration until after Cinnabar Beta
* Wed Jul 28 2004 - [email protected]
- greenline integration
* Fri Jul 23 2004 - [email protected]
- adapted source tarball name for build 15
* Sat Jun 26 2004 - [email protected]
- Changed SUNW_Category to "APOC,application,JDS3"
* Mon May 31 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 1.0-0
  Changes relating to inetd enabled startup
* Tue May 04 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-26
  Reverting to "inetd enabled install"
* Tue Apr 27 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-25
  Merging apocd, apocdctl & setenv.sh into apocd
* Mon Apr 26 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-24
  Including os.properties in apocd.jar to provide correct default
* Thu Apr 15 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-23
  Turning off Autoreqprov
* Tue Apr 13 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0-1-22
  Changing name of libapi.so to libapoc.so
* Fri Feb 20 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-20
  Performance improvements
* Mon Feb 16 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-19
  Increasing MaxRequestSize to support larger Active Directory tokens
* Mon Feb 11 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-18
  papi reconnection & GSSAPI/Active Directory support
* Mon Feb 9 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-17
  ServiceName & ServiceContainer no longer configurable
* Wed Feb 4 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-16
  Don't overwrite properties files
* Mon Feb 2 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-15
  Change detection timers
* Fri Jan 30 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-14
  Exception logging, timers etc.
* Mon Jan 19 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-13
  Add argument for inetd start
* Tue Jan 13 2004 - Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-12
  And back to inetd again
* Mon Dec 22 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-11
  Switching from inetd to init
* Fri Dec 19 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-10
  Changing policymgr.properties permissions
* Mon Dec 1 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-9
  Update license
* Thu Nov 27 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-8
  Fix for 4960347
* Tue Nov 20 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-7
  Moving back to berkeley db 4 due to incompatability with StarOffice
* Tue Nov 18 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-6
  YaST modules moved to seperate rpm
* Fri Nov 14 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-5
  Moving to berkeley db version 4
* Wed Nov 12 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-4
  Fix for 4952794
* Thu Nov 6 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-2
  Feature complete apocd
* Fri Jul 11 2003 Geoff Higgins <geoff.higgins@@sun.com>
- Version 0.1-1
  Initial apocd