base-specs/dbus-python.spec
author yippi
Thu, 31 May 2012 20:16:52 +0000
changeset 22481 1ff6784d9b6f
parent 22410 a281d5a9e77c
permissions -rw-r--r--
2012-05-31 Brian Cameron <[email protected]> * base-specs/shared-mime-info.spec: Bump to 1.0. * base-specs/nautilus.spec, base-specs/pulseaudio.spec, base-specs/gnome-settings-daemon.spec, specs/SUNWdconf.spec: Add patch comments. * base-specs/gnome-panel.spec: Add --disable-telepathy-glib so it does not build with this module we do not deliver.

#
# spec file for package dbus-python
#
# Copyright (c) 2006, 2012, Oracle and/or its affiliates. All rights reserved.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
# bugdb: bugzilla.freedesktop.org
#
%{?!pythonver:%define pythonver 2.6}

%define OSR 4092:0.60

Name:         dbus-python
License:      MIT
Vendor:       freedesktop.org
Group:        System/Libraries
Version:      1.0.0
Release:      1
Distribution: Java Desktop System
Summary:      Python bindings for D-Bus
Source:       http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
URL:          http://www.freedesktop.org/wiki/Software_2fdbus
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

BuildRequires: glib2-devel >= %glib2_version
BuildRequires: libxml2-devel >= %libxml2_version
BuildRequires: python-devel >= %{pythonver}
Requires: glib2 >= %glib2_version
Requires: libxml2 >= %libxml2_version
Requires: python >= %{pythonver}

%description
Python bindings for D-Bus.

%package devel
Summary:      Simple IPC library based on messages
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
Python bindings for D-Bus.

%prep
%setup -q

%build
export PYTHON=/usr/bin/python%{pythonver}
export PYTHON_VERSION=%{pythonver}
aclocal $ACLOCAL_FLAGS -I ./m4
autoconf
automake -a -c -f
export CFLAGS="%optflags -D_REENTRANT"
export LDFLAGS="%_ldflags"
./configure --prefix=%{_prefix}			\
            --includedir=%{_includedir}		\
            --sysconfdir=%{_sysconfdir}		\
            --libdir=%{_libdir}			\
            --bindir=%{_bindir}			\
            --localstatedir=%{_localstatedir}	\
            --with-dbus-user=root		\
            --with-dbus-daemondir=%{_basedir}/lib \
            --mandir=%{_mandir}			\
            --datadir=%{_datadir}		\
            --disable-static
make

%install
make install DESTDIR=$RPM_BUILD_ROOT

find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'

# move to vendor-packages
PYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
(
    cd ${PYLIBDIR}/site-packages
    find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
)
rm -rf ${PYLIBDIR}/site-packages


find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus*.so*
%{_datadir}/man/*
%{_datadir}/dbus-1/*

%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*

%changelog
* Wed May 02 2012 - Brian Cameron  <[email protected]>
- Bump to 1.0.0.
* Tue Sep 13 2011 - Brian Cameron  <[email protected]>
- Bump to 0.84.0.
* Mon Dec 27 2010 - Brian Cameron  <[email protected]>
- Bump to 0.83.2.
* Fri Feb 19 2010 - Brian Cameron  <[email protected]>
- Bump to 0.83.1.
* Tue Oct 13 2009 - Brian Cameron  <[email protected]>
- Do not install .pyo files.
* Thu Mar 19 2009 - [email protected]
- Remove patch dbus-python-01-fix-wrong-python25-includes.diff and instead
  set PYTHON_VERSION, which also ensures that the right python includes are
  used.
* Thu Mar 05 2009 - [email protected]
- Made it possible to build both Python 2.4 and 2.6 bindings.
* Mon Aug 15 2008 - [email protected]
- Remove method to find python headers by means of python-config from
  configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
* Thu Jul 24 2008 - [email protected]
- bump to 0.83.0.
* Mon Dec 10 2007 - [email protected]
- Bump to 0.82.4.
* Wed Nov 07 2007 - [email protected]
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
  See bugster 6615221
* Wed Oct 10 2007 - [email protected]
- Don't delete *.pyc files - they are needed.
* Fri Sep 28 2007 - [email protected]
- convert to new style multi-ISA build
* Mon Aug 06 2007 - [email protected]
- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
* Sun Apr  1 2007 - [email protected]
- add missing aclocal calls
* Wed Mar 15 2007 - [email protected]
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - [email protected]
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - [email protected]
- Bump to 0.80.2.
* Thu Jan 25 2007 - [email protected]
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - [email protected]
- Created.