base-specs/python-twisted.spec
author yippi
Thu, 31 May 2012 20:16:52 +0000
changeset 22481 1ff6784d9b6f
parent 21106 512b7ea38e70
permissions -rw-r--r--
2012-05-31 Brian Cameron <[email protected]> * base-specs/shared-mime-info.spec: Bump to 1.0. * base-specs/nautilus.spec, base-specs/pulseaudio.spec, base-specs/gnome-settings-daemon.spec, specs/SUNWdconf.spec: Add patch comments. * base-specs/gnome-panel.spec: Add --disable-telepathy-glib so it does not build with this module we do not deliver.

#
# base spec file for package python-twisted
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner jouby 
#

%define name Twisted

%define OSR 8094:2.5.0

Name:                    python-twisted
Summary:                 Event-based framework for internet applications
Vendor:                  twistedmatrix.org
URL:                     http://twistedmatrix.com/trac/
Version:                 10.1.0
Source:                  http://tmrc.mit.edu/mirror/twisted/Twisted/10.1/Twisted-%{version}.tar.bz2
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                Python

%{?!pythonver:%define pythonver 2.6}

%prep
%setup -q -n Twisted-%version

%build
python%{pythonver} setup.py build

%install
rm -rf $RPM_BUILD_ROOT
python%{pythonver} setup.py install --root=$RPM_BUILD_ROOT --prefix=%_prefix

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

mkdir -p ${RPM_BUILD_ROOT}%{_basedir}/demo/twisted-python%{pythonver}
mv ${RPM_BUILD_ROOT}%{_bindir}/* \
   ${RPM_BUILD_ROOT}%{_basedir}/demo/twisted-python%{pythonver}
rmdir ${RPM_BUILD_ROOT}%{_bindir}

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Wed Oct 27 2010 - [email protected]
- Bump to 10.1.0.
* Fri Mar 12 2010 - [email protected]
- Bump to 10.0.0 since it has been determined OSR is not needed.
* Fri Feb 19 2010 - [email protected]
- Revert to 8.2 until OSR can be completed.
* Wed Jan 27 2010 - [email protected]
- Bump to 9.0.
* Thu Oct 27 2009 - [email protected]
- Change the owner to jouby
* Fri Jan 23 2009 - [email protected]
- Updated to 8.2.
* Thu Nov 27 2008 - [email protected]
- Split from SUNWpython-twisted.spec
* Wed Jul 23 2008 - [email protected]
- Bump to 8.1.
* Tue Feb 19 2008 - [email protected]
- Move demo scripts from /usr/bin to /usr/demo/twisted
* Tue Feb 12 2008 - [email protected]
- initial version