base-specs/speex.spec
author yippi
Thu, 31 May 2012 20:16:52 +0000
changeset 22481 1ff6784d9b6f
parent 20384 6a50803f5a65
permissions -rw-r--r--
2012-05-31 Brian Cameron <[email protected]> * base-specs/shared-mime-info.spec: Bump to 1.0. * base-specs/nautilus.spec, base-specs/pulseaudio.spec, base-specs/gnome-settings-daemon.spec, specs/SUNWdconf.spec: Add patch comments. * base-specs/gnome-panel.spec: Add --disable-telepathy-glib so it does not build with this module we do not deliver.

#
# spec file for package speex
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
# bugdb: https://trac.xiph.org/
#
Name:         speex
License:      Xiph.org BSD-style, binaries also use some LGPL v2 code.
Group:        Libraries/Multimedia
%define tarball_version 1.2rc1
Version:      1.2
Release:      1
Distribution: Java Desktop System
Vendor:       Xiph
Summary:      An open-source, patent-free speech codec
Source:       http://downloads.us.xiph.org/releases/%{name}/%{name}-%{tarball_version}.tar.gz
# date:2009-02-19 type:branding owner:mattman
Patch1:       speex-01-manpages.diff
# date:2010-11-15 type:branding owner:davelam
Patch2:       speex-02-visibility-hidden.diff
URL:          http://speex.org/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_docdir}/%{name}
Autoreqprov:  on

%description
Speex is a patent-free audio codec designed especially for voice (unlike 
Vorbis which targets general audio) signals and providing good narrowband 
and wideband quality. This project aims to be complementary to the Vorbis
codec.

%package devel
Summary:        Speex development files
Group:          Development/Libraries
Requires:       %{name} = %{version}

%description devel
Speex development files.

%prep
%setup -q -n %{name}-%{tarball_version}
%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export LDFLAGS="%_ldflags"
export CFLAGS="%optflags"

aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf
./configure --enable-shared     \
            --enable-static     \
            --prefix=%{_prefix} \
            --libdir=%{_libdir} \
            --bindir=%{_bindir} \
            --sysconfdir=%{_sysconfdir} \
            --mandir=%{_mandir}

make

%install
make DESTDIR=$RPM_BUILD_ROOT install

#Clean up unpackaged files
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc COPYING AUTHORS ChangeLog NEWS README
%{_datadir}/doc/*
%{_datadir}/man/man1/speexenc.1*
%{_datadir}/man/man1/speexdec.1*
%attr(755,root,root) %{_bindir}/speex*
%attr(755,root,root) %{_libdir}/libspeex*.so*

%files devel
%defattr(-,root,root)
%{_includedir}/speex/speex*.h
%{_datadir}/aclocal/speex.m4
%{_libdir}/pkgconfig/speex.pc

%changelog
* Thu Sep 10 2009 - [email protected]
- Add 64-bit support
* Thu Feb 19 2009 - [email protected]
- Add manpages patch for attributes and ARC comment
* Fri Dec 05 2008 - [email protected]
- Bump to 1.2rc1
* Tue Apr 29 2008 - [email protected]
- Bump to 1.2beta3.2
* Tue Dec 11 2007 - [email protected]
- Bump to 1.2beta3.
* Wed Nov 07 2007 - [email protected]
- Bump to 1.2beta2.
* Thu May 17 2007 - [email protected]
- Use a numeric version number. 'beta' is not permitted by WOS integration
  scripts.
* Fri Dec 01 2006 - [email protected]
- Bump to 1.2beta1. Remove obsolete patch, 01-empty-struct.
* Thu Jul 20 2006 - [email protected]
- Bump to 1.1.12. Add patch, 01-empty-struct, to fix empty struct build error.
* Wed Jan 04 2006 - [email protected]
- Single threaded make because of timing issues.
* Tue Jan 03 2006 - [email protected]
- Bump to 1.1.11.1.
* Tue Aug 23 2005 - [email protected]
- Remove an incorrect line from %files.
* Mon Aug 16 2005 - [email protected]
- Bump to 1.1.10.
* Tue Aug 02 2005 - [email protected]
- Change copyright to license
* Tue Jul 26 2005 - [email protected]
- Fix defattr for files and files devel
* Thu Jul 21 2005 - [email protected]
- Remove *.a and *.la files. Fix typo. Add proper configure arguments
* Wed Jul 20 2005 - [email protected]
- Initial spec file checkin