specs/SUNWccsm.spec
author davelam
Wed, 08 Dec 2010 07:06:08 +0000
branchgnome-2-30
changeset 21135 e59609751822
parent 20762 9ac90298058f
child 21395 041dce1b104f
permissions -rw-r--r--
2010-12-08 Dave Lin <[email protected]> * include/gnome-consolidation.inc * include/options.inc: Add option "--with-svr4" to make build based on SVR4 packaging mechanism. * include/l10n-consolidation.inc: Added(empty). * specs/SUNWgnome-display-mgr.spec: Removed duplicated line in %files. * specs/SUNWccsm.spec: Corrected dependency package name. * specs/SUNWevolution-libs.spec: Corrected dependency package name.

#
# spec file for package SUNWccsm
####################################################################
# compizconfig-settings-manager(ccsm): A fully featured Python/GTK 
# based settings manager for the CompizConfig system.
####################################################################
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner erwannc

%include Solaris.inc

%define OSR 8297:1.6.2

%define src_name ccsm

Name:                    SUNWccsm
IPS_package_name:        desktop/compiz/ccsm
Meta(info.classification): %{classification_prefix}:Applications/Graphics and Imaging
Summary:                 ccsm settings manager for the CompizConfig system
License:                 GPL v2
Vendor:                  compiz-fusion.org
Version:                 0.8.2
Source:			 http://releases.compiz-fusion.org/%{version}/%{src_name}-%{version}.tar.bz2	 
# owner:jedy date:2008-08-11 type:branding
Patch1:			 ccsm-01-desktop.diff
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright

%ifnarch sparc
# these packages are only avavilable on x86
# =========================================

BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
%include gnome-consolidation.inc
# add build and runtime dependencies here:
BuildRequires:  SUNWgnome-python26-libs-devel
BuildRequires:  SUNWPython26
BuildRequires:  SUNWpython26-setuptools
BuildRequires:  SUNWcompizconfig-python
BuildRequires:  SUNWlibsexy
Requires:       SUNWdbus-python26
Requires:       SUNWgnome-python26-libs
Requires:       SUNWPython26
Requires:       SUNWcompizconfig-python
Requires:       SUNWlibsexy
Requires:       SUNWdesktop-cache
%include default-depend.inc
%include gnome-consolidation.inc

%define pythonver 2.6

%if %build_l10n
%package l10n
IPS_package_name:        desktop/compiz/ccsm/l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir(relocate_from:%{_prefix}): %{_dto_il10n_basedir}
%include default-depend.inc
%include gnome-consolidation.inc
Requires:                %{name}
%endif

%prep
%setup -q -n %{src_name}-%version
%patch1 -p1

%build
python%{pythonver} setup.py build --prefix=%{_prefix}

%install
rm -rf $RPM_BUILD_ROOT
python%{pythonver} setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

#
# when not building -l10n packages, remove anything l10n related from
# $RPM_BUILD_ROOT
#
%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%post
%restart_fmri desktop-mime-cache mime-types-cache

%postun
%restart_fmri desktop-mime-cache mime-types-cache

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/python%{pythonver}/vendor-packages
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/ccsm
%{_datadir}/ccsm/*
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/ccsm.desktop
%attr (0755, root, other) %{_datadir}/icons
#
# The files included here should match the ones removed in %install
#
%if %build_l10n
%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale/*
%endif

# endif for "ifnarch sparc"
%endif

%changelog
* Thu Aug 13 2009 - [email protected]
- Bump to 0.8.2.
* Fri Apr  3 2009 - [email protected]
- use desktop-cache instead of postrun
* Mon Aug 11 2008 - [email protected]
- Add 02-desktop.diff to hide the menu enty form the menu because it has
  been integrated into gnome-appearance-properties.
* Tue Jun 01 2008 - [email protected]
- Fix perms in %files.
* Wed Mar 26 2008 - [email protected]
- change to not build this component on SPARC
* Fri Feb 22 2008 - [email protected]
- Add ccsm-01-po.diff to add cs.po, es.po, hu.po, ja.po, ko.po from HEAD.
* Wed Feb 13 2008 - [email protected]
- Moved to SFO
* Wed Nov 14 2007 - [email protected]
- Add l10n package.
* Mon Oct 29 2007 - [email protected]
- Bump to 0.6.0
* Sat Sep 08 2007 - [email protected]
- Correct rules, remove -root, fix Python library location
* Fri Aug  14 2007 - [email protected]
- Initial spec