SUNWlibcanberra.spec
author chrisk
Mon, 31 Aug 2009 16:23:04 +0000
changeset 16434 f21f22550fe9
parent 16162 021204bdacca
child 16547 6c3a78669b5f
permissions -rw-r--r--
2009-08-31 Christian Kelly <[email protected]> * base-specs/*.spec, *.spec: Change owner field to be parsable with spectool.

#
# spec file for package SUNWlibcanberra
#
# includes module(s): libcanberra
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
# bugdb: bugzilla.freedesktop.org
#
%include Solaris.inc

%ifarch amd64 sparcv9
%include arch64.inc
%use libcanberra_64 = libcanberra.spec
%endif

%include base.inc
%use libcanberra = libcanberra.spec

Name:                    SUNWlibcanberra
Summary:                 Event Sound API Using XDG Sound Theming Specification
Version:                 %{libcanberra.version}
Source1:                 %{name}-manpages-0.1.tar.gz
SUNW_Copyright:          %{name}.copyright
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires: SUNWgtk2
Requires: SUNWlibcanberra-root
Requires: SUNWxdg-sound-theme
Requires: SUNWgnome-media
Requires: SUNWogg-vorbis
Requires: SUNWltdl
Requires: SUNWdesktop-cache
BuildRequires: SUNWgtk2-devel
BuildRequires: SUNWgnome-media-devel
BuildRequires: SUNWogg-vorbis-devel

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
rm -rf %name-%version
mkdir %name-%version

mkdir %name-%version/%base_arch
%libcanberra.prep -d %name-%version/%base_arch

%ifarch amd64 sparcv9
mkdir %name-%version/%_arch64
%libcanberra_64.prep -d %name-%version/%_arch64
%endif

cd %{_builddir}/%{name}-%{version}
gzcat %SOURCE1 | tar xf -

%build
export PKG_CONFIG_LIBDIR=%{_pkg_config_path}
%libcanberra.build -d %name-%version/%base_arch

%ifarch amd64 sparcv9
export PKG_CONFIG_LIBDIR=%{_pkg_config_path64}
%libcanberra_64.build -d %name-%version/%_arch64
%endif

%install
%libcanberra.install -d %name-%version/%base_arch

%ifarch amd64 sparcv9
%libcanberra_64.install -d %name-%version/%_arch64
%endif

cd %{_builddir}/%{name}-%{version}/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%post
%restart_fmri gconf-cache

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gtk-2.0
%{_libdir}/libcanberra-%{version}
%{_libdir}/lib*.so*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%{_libdir}/%{_arch64}/gtk-2.0
%{_libdir}/%{_arch64}/libcanberra-%{version}
%{_libdir}/%{_arch64}/lib*.so*
%endif
%dir %attr (0755, root, sys) %{_datadir}
%doc -d %{base_arch} %{libcanberra.name}-%{libcanberra.version}/README
%doc -d %{base_arch} %{libcanberra.name}-%{libcanberra.version}/doc/README
%doc(bzip2) -d %{base_arch} %{libcanberra.name}-%{libcanberra.version}/LGPL
%dir %attr (0755, root, other) %{_datadir}/doc
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/*
%{_datadir}/gtk-doc
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%dir %attr(0755, root, bin) %{_mandir}/man3
%{_mandir}/man1/*
%{_mandir}/man3/*

%files root
%defattr(-, root, sys)
%attr(0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/libcanberra.schemas

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
%{_libdir}/%{_arch64}/pkgconfig/*
%endif
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%dir %attr (0755, root, other) %{_datadir}/doc/libcanberra
%{_datadir}/doc/libcanberra/*
%dir %attr (0755, root, other) %{_datadir}/gnome

%changelog
* Fri Jul 29 2009 - [email protected]
- Add 64-bit support
* Wed Jul 01 2009 - [email protected]
- Bump to 0.14.
* Wed Jun 24 2009 - [email protected]
- Bump to 0.13.  Remove upstream patch libcanberra-02-close-file.diff.
* Mon Apr 13 2009 - [email protected]
- Bump to 0.12.
* Fri Apr  3 2009 - [email protected]
- use desktop-cache instead of postrun
* Tue Feb 10 2009 - [email protected]
- Add Requires: SUNWltdl to fix issue #5 for CR6753371
* Wed Jan 21 2009 - [email protected]
- Bump to 0.11.  Remove upstream patches.
* Thu Jan 15 2008 - [email protected]
- Add a patch to fix the OSS backend so it works.
* Thu Oct 30 2008 - [email protected]
- Add patch libcanberra-02-gstreamer.diff to fix bug where libcanberra core
  dumps when it tries to play a second sound.  Fixes bugster bug #6761078.
* Mon Oct 13 2008 - [email protected]
- Bump to 0.10.  Add root package and %post and %preun sections for the
  new GConf schemas.
* Tue Sep 09 2008 - [email protected]
- Bump to 0.9.  Remove upstream patches libcanberra-02-gstreamer.diff and
  libcanberra-03-fix-gst-play.diff.
* Fri Aug 29 2008 - [email protected]
- Add patch libcanberra-03-fix-gst-play so it actually plays the sound.
* Fri Aug 29 2008 - [email protected]
- Add patch libcanberra-02-gstreamer.diff to add audioconvert and audioresample
  plugins to the output pipeline, so it works on Solaris.
* Thu Aug 28 2008 - [email protected]
- Bump to 0.8.  Now has its own GStreamer support, so removed our patch.
* Wed Aug 20 2008 - [email protected]
- Add Requires/BuildRequires and patch libcanberra-02-gstreamer.diff to support
  a GStreamer backend.
* Thu Aug 14 2008 - [email protected]
- Created with version 0.6.