SUNWpysqlite.spec
author chrisk
Mon, 31 Aug 2009 16:23:04 +0000
changeset 16434 f21f22550fe9
parent 16280 462de9e707f7
child 16907 c6ddec838f33
permissions -rw-r--r--
2009-08-31 Christian Kelly <[email protected]> * base-specs/*.spec, *.spec: Change owner field to be parsable with spectool.

#
# spec file for package SUNWpysqlite
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner dkenny
#

%include Solaris.inc

%use pysqlite = pysqlite.spec
%define pythonver 2.4

Name:                    SUNWpysqlite
Summary:                 Python DB-API 2.0 interface for the SQLite
%define                  major_version 2.4
Version:                 %{major_version}.1
Vendor:                  %{pysqlite.vendor}
License:                 %{pysqlite.license}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                SUNWPython
Requires:                SUNWsqlite3
BuildRequires:           SUNWPython-devel
BuildRequires:           SUNWsqlite3
BuildRequires:           SUNWpython-setuptools

%include default-depend.inc

%prep
rm -rf %name-%version
mkdir -p %name-%version
%pysqlite.prep -d %name-%version

%build
%pysqlite.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%pysqlite.install -d %name-%version

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr(0755, root, bin) %{_prefix}/lib/python%{pythonver}
%dir %attr(0755, root, bin) %{_prefix}/lib/python%{pythonver}/vendor-packages
%dir %attr(0755, root, bin) %{_prefix}/lib/python%{pythonver}/vendor-packages/*
%{_prefix}/lib/python%{pythonver}/vendor-packages/pysqlite2/*
%doc -d %{pysqlite.name}-%{pysqlite.version} LICENSE PKG-INFO
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc

%changelog
* Thu Feb 12 2009 - [email protected]
- Now use pysqlite.spec file
* Tue Nov 18 2008 - [email protected]
- Fix installation directory problem.
* Tue Sep 16 2008 - [email protected]
- Update copyright
* Tue Mar 11 2008 - [email protected]
- Change SUNWsqlite3-devel reference to SUNWsqlite3.
* Tue Feb 12 2008 - [email protected]
- Change SFEsqlite require to SUNWsqlite.
* Tue Feb 12 2008 - [email protected]
- initial version