base-specs/gamin.spec
author chrisk
Mon, 31 Aug 2009 16:23:04 +0000
changeset 16434 f21f22550fe9
parent 16426 6e0af232ec80
child 16764 481bc9a4a0d0
permissions -rw-r--r--
2009-08-31 Christian Kelly <[email protected]> * base-specs/*.spec, *.spec: Change owner field to be parsable with spectool.

#
# spec file for package SUNWgamin, SUNWgamin-devel
#
# includes module(s): gamin
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner lin
#

%define OSR gnome.org:0

Name:		gamin
Summary:	Library providing the FAM File Alteration Monitor API
URL:		http://www.gnome.org/~veillard/gamin/
Version:	0.1.10
Source0:	http://www.gnome.org/~veillard/gamin/sources/%{name}-%{version}.tar.bz2
# owner:lin date:2007-12-05 type:feature bugzilla:491319
Patch1:		gamin-01-all.diff
License:	LGPL

%prep
%setup -q -n %{name}-%{version}
%patch1 -p0

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --copy --force
aclocal
autoconf --force
automake -a -c -f

config=./configure

export CFLAGS="%optflags"
export LDFLAGS="%_ldflags"
$config	--prefix=%{_prefix}		\
	--libdir=%{_libdir}		\
	--libexecdir=%{_libexecdir}	\
	--datadir=%{_datadir}		\
	--mandir=%{_mandir}		\
	--sysconfdir=%{_sysconfdir}	\
	--disable-static
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir}
#
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Tue Nov 25 2008 - [email protected]
- Bump to 0.1.10
* Wed Dec 05 2007 - [email protected]
- Changed the type of gamin patch 01 to feature.
* Sat Oct 13 2007 - [email protected]
- Initial FEN backend
* Sun Apr 14 2007 - [email protected]
- Initial version