base-specs/gst-python.spec
author chrisk
Mon, 31 Aug 2009 16:23:04 +0000
changeset 16434 f21f22550fe9
parent 16429 fe72291e50fd
child 16741 bdc3521a980c
permissions -rw-r--r--
2009-08-31 Christian Kelly <[email protected]> * base-specs/*.spec, *.spec: Change owner field to be parsable with spectool.

#
# base spec file for package gst-python
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
#
%{?!pythonver:%define pythonver 2.4}

%define OSR 8324:0.10.10

Name:                    gst-python
License:                 LGPL v2.1
Group:                   Libraries/Multimedia
Version:                 0.10.16
Distribution:            Java Desktop System
Vendor:                  Sun Microsystems, Inc.
Summary:                 Python bindings for the GStreamer streaming media framework
Source:                  http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
URL:                     http://gstreamer.freedesktop.org/src/gst-python/
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                python
Requires:                gstreamer

%prep
%setup -q -n %name-%version

%build
export PYTHON=/usr/bin/python%{pythonver}
export PKG_CONFIG_PATH=/usr/lib/python%{pythonver}/pkgconfig
aclocal -I ./common/m4 $ACLOCAL_FLAGS
autoconf
automake
./configure --prefix=%{_prefix}
make

%install
make install DESTDIR=$RPM_BUILD_ROOT

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Fri Aug 14 2009 - [email protected]
- Bump to 0.10.16.
* Mon May 11 2009 - [email protected]
- Bump to 0.10.15.
* Tue Mar 03 2009 - [email protected]
- Use find command to remove .la files.
* Mon Jan 19 2009 - [email protected]
- Bump to 0.10.14.
* Mon Nov 24 2008 - [email protected]
- split from SUNWgst-python.spec
* Mon Oct 13 2008 - [email protected]
- Bump to 0.10.13.  Remove upstream patch gst-python-01-pipelinetester.diff.
* Fri Sep 12 2008 - [email protected]
- Update copyright
* Wed Jul 16 2008 - [email protected]
- Update %files for newly delivered library.
* Thu Jun 19 2008 - [email protected]
- Bump to 0.10.12.
* Thu Mar 20 2008 - [email protected]
- Bump to 0.10.11.
* Tue Mar 18 2008 - [email protected]
- Add Build/Requires for SUNWgnome-python-libs and SUNWgnome-media.
* Tue Feb 12 2008 - [email protected]
- initial version