base-specs/libvisual.spec
author chrisk
Mon, 31 Aug 2009 16:23:04 +0000
changeset 16434 f21f22550fe9
parent 16431 d7743d81b302
child 17821 332d8580d058
permissions -rw-r--r--
2009-08-31 Christian Kelly <[email protected]> * base-specs/*.spec, *.spec: Change owner field to be parsable with spectool.

#
# spec file for package libvisual.spec
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner jerrytan 
# bugdb: http://sourceforge.net/tracker/index.php?func=detail&group_id=106542&atid=644748&aid=

%define OSR 10429:0.x

Name:                   libvisual
License:		LGPL v2.1
Summary:                Libvisual provides a convenient API for writing visualization plugins
Version:                0.4.0
Vendor:                 Sun Microsystems, Inc.
URL:                    http://localhost.nl/~synap/libvisual-wiki/index.php/Main_Page
Source:                 http://downloads.sourceforge.net/libvisual/libvisual-%{version}.tar.bz2
# date:2008-11-25 owner:jerrytan type:branding
Patch1:                 libvisual-01-solaris.diff
# date:2008-11-25 owner:jerrytan type:bug bugster:6836607 
Patch2:			libvisual-02-compiler.diff
# date:2008-12-07 owner:jerrytan type:feature bugster:6788530
Patch3:			libvisual-03-map.diff

%package devel
Summary:        %{summary} - development files
Requires: %name
Requires: SUNWgnome-common-devel

%prep
%setup -q -n libvisual-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

./configure --prefix=%{_prefix}		\
	    --mandir=%{_mandir}		\
            --datadir=%{_datadir}	\
            --sysconfdir=%{_sysconfdir} \
            --enable-shared=yes		\
	    --enable-static=no


make -j$CPUS 

%install
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT/%{_libdir}/lib*.*a

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755,root,bin) %{_libdir}
%{_libdir}/lib*.so*
%dir %attr (0755, root, other)  %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*.pc

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%changelog
* Tue Nov 25 2008 - [email protected]
- add license tag
- rename SFElibvisual to libvisual
- use sun compiler 12 instead of gcc
* Sun Jun 29 2008 - [email protected]
- force /usr/sfw/bin/gcc, use gcc cflags instead of studio
* Thu Jan 24 2008 - [email protected]
- Initial spec.