base-specs/raptor.spec
author chrisk
Mon, 31 Aug 2009 16:23:04 +0000
changeset 16434 f21f22550fe9
parent 16380 227512bf4a00
child 16573 6a314455c3b0
permissions -rw-r--r--
2009-08-31 Christian Kelly <[email protected]> * base-specs/*.spec, *.spec: Change owner field to be parsable with spectool.

#
# spec file for package raptor
# Copyright (c) 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.

%define owner jerrytan

Name:                raptor
Summary:             RDF Parser Library - RDF parser utility
License:             LGPL v2
Version:             1.4.19
Distribution:        Java Desktop System
Vendor:              Sun Microsystems, Inc.
Group:               System/Libraries
URL:                 http://librdf.org/raptor
Source:              http://download.librdf.org/source/raptor-%{version}.tar.gz
BuildRoot:           %{_tmppath}/%{name}-%{version}-build
Docdir:              %{_defaultdocdir}/doc

%description
Raptor is a free software C library that provides a set of parsers  and
serializers that generate Resource Description Framework (RDF)  triples
by parsing syntaxes or serialize the triples into a syntax.

%package devel
Summary:                 Development package for libraptor
%description devel
This package contains the header files and documentation
needed to develop applications with libraptor

%prep
%setup 

%build

export CFLAGS="%optflags"
export LDFLAGS="%{_ldflags}"

./configure --prefix=%{_prefix}  \
            --libdir=%{_libdir} \
            --includedir=%{_includedir} \
            --mandir=%{_mandir} \
            --enable-static=no

make 

%install
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog README NEWS
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/libraptor.*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, bin) %{_mandir}
%dir %attr (0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*.1
%dir %attr (0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*.3

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gtk-doc

%changelog
* Sat Aug 15 2009 - [email protected]
- Bump to 1.4.19.
* Fri Jul 31 2009 <[email protected]>
- add raptor into spec-files
* Tue Feb 12 2008 <pradhap (at) gmail.com>
- Bumped up the version to 1.4.14
* Mon Nov 06 2006 - Eric Boutilier
- Fixed attributes and created devel sub pkg
* Wed Sep 27 2006 - Eric Boutilier
- Initial spec