SUNWgst-python.spec
author yippi
Mon, 19 Jan 2009 17:32:29 +0000
branchgnome-2-24
changeset 14173 fe63d4719576
parent 14088 c2fa9f48a10f
child 14202 fc80c50f84e9
permissions -rw-r--r--
2009-01-19 Brian Cameron <[email protected]> * SUNWpython-setuptools.spec, SUNWpython25-setuptools.spec, base-specs/python-setuptools.spec, copyright/SUNWpython-setuptools.copyright: Move from spec-files-other. * SUNWgnome-python-desktop.spec, SUNWgnome-menu-editor.spec, SUNWdbus-bindings.spec, SUNWgnome-panel.spec, SUNWgnome-applets.spec, SUNWPython-extra.spec, SUNWgnome-a11y-libs.spec, SUNWlibgsf.spec, SUNWgnome-python-libs.spec, SUNWgst-python.spec, SUNWgnome-python-extras.spec, SUNWIPython.spec, SUNWgnome-games.spec, SUNWgnome-img-editor.spec, SUNWgtk-vnc.spec, SUNWpysqlite.spec, SUNWavahi-bridge-dsd.spec: Make all modules with Python interfaces depend on setuptools. Fixes bug #5795062.

#
# spec file for package SUNWgst-python
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dkenny
#
%include Solaris.inc

Name:                    SUNWgst-python
Summary:                 Python bindings for the GStreamer streaming media framework
URL:                     http://gstreamer.freedesktop.org/src/gst-python/
Version:                 0.10.13
Source:                  http://gstreamer.freedesktop.org/src/gst-python/gst-python-%{version}.tar.bz2
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                SUNWPython
Requires:                SUNWgnome-python-libs
Requires:                SUNWgnome-media
BuildRequires:           SUNWgnome-python-libs-devel
BuildRequires:           SUNWgnome-media-devel
BuildRequires:           SUNWpython-setuptools

%include default-depend.inc

%define pythonver 2.4

%prep
%setup -q -n gst-python-%version

%build
./configure --prefix=%{_prefix}
make

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

rm $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/*.la

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/python%{pythonver}/vendor-packages/gst-0.10/*
%{_libdir}/python%{pythonver}/vendor-packages/pygst.pth
%{_libdir}/python%{pythonver}/vendor-packages/pygst.py
%{_libdir}/python%{pythonver}/vendor-packages/*.so
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gst-python
%doc AUTHORS README
%doc(bzip2) COPYING ChangeLog NEWS
%dir %attr (0755, root, other) %{_datadir}/doc

%changelog
* Thu Dec 11 2008 - [email protected]
- Bump to 0.10.13.

* Fri Sep 12 2008 - [email protected]
- Update copyright

* Wed Jul 16 2008 - [email protected]
- Update %files for newly delivered library.

* Thu Jun 19 2008 - [email protected]
- Bump to 0.10.12.

* Thu Mar 20 2008 - [email protected]
- Bump to 0.10.11.

* Tue Mar 18 2008 - [email protected]
- Add Build/Requires for SUNWgnome-python-libs and SUNWgnome-media.

* Tue Feb 12 2008 - [email protected]
- initial version