components/openca-ocspd/Makefile
author Jan Parcel <jan.parcel@oracle.com>
Thu, 28 Jul 2016 15:43:02 -0700
branchs11u3-sru
changeset 6529 50a81baffe58
parent 6363 052c5c0a107d
child 6627 25e0012b607e
permissions -rw-r--r--
24370217 The pkg openca-ocspd v3.1.2 Makefile is missing pkg publish dependencies
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License (the "License").
# You may not use this file except in compliance with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END

#
# Copyright (c) 2016, Oracle and/or its affiliates. All rights reserved.
#

include ../../make-rules/shared-macros.mk

BITS=			64
COMPONENT_NAME=		openca-ocspd
COMPONENT_VERSION=	3.1.2

# Version 3.1.2 of openca-ocspd has not been released, yet. There is no source
# tarball for it. In Solaris 12, Userland consolidation has infrastructure
# to fetch sources from SCM repository based on a specified git commit hash.
# Such infrastructure is not present in Solaris 11.3. So we take the latest
# tarball with 3.1.1 and apply few patches on top of it to get the same sources
# as in Solaris 12. These are named 001-*, 002-* and 003-*.
# Once version 3.1.2 is available, simply delete these patches.
COMPONENT_PROJECT_URL=  https://www.openca.org/projects/ocspd/
COMPONENT_SRC=          $(COMPONENT_NAME)-3.1.1
COMPONENT_ARCHIVE=      $(COMPONENT_SRC).tar.gz
COMPONENT_ARCHIVE_HASH= \
        sha256:10d56cecb862d94ed8742bdf52958cebe1b3f8d87625ba014b0ae2b7c4820de5
COMPONENT_ARCHIVE_URL=  \
        http://downloads.sourceforge.net/project/openca/$(COMPONENT_NAME)/releases/v3.1.1/sources/$(COMPONENT_ARCHIVE)
COMPONENT_BUGDB=        library/smartcard

TPNO =			28048

include $(WS_MAKE_RULES)/prep.mk
include $(WS_MAKE_RULES)/configure.mk
include $(WS_MAKE_RULES)/ips.mk

PKG_PROTO_DIRS +=	$(COMPONENT_SRC)/docs
PKG_PROTO_DIRS +=	$(COMPONENT_SRC)/etc/ca.d

POD2MAN_PATH =		/usr/perl5/$(PERL_VERSION)/bin

COMPONENT_BUILD_ENV +=	PATH="$(PATH):$(POD2MAN_PATH)"

CONFIGURE_BINDIR.64 =	$(CONFIGURE_PREFIX)/bin
CONFIGURE_SBINDIR.64 =	$(CONFIGURE_PREFIX)/sbin

CONFIGURE_ENV +=	"CFLAGS=$(CFLAGS)"

# common targets
configure:      $(CONFIGURE_64)

build:          $(BUILD_64)

install:        $(INSTALL_64)

# Skip test because of set up requirements.
#
# The upstream archive includes a test script (test.sh), which tries to run
# "openssl ocsp" command multiple times. However, it assumes that we already
# have necessary pem files (keys/certficates for CA, ocspd daemon, and others,
# and also the CRL), and those files are not included in the archive.
#
# To test manually, follow a guide document for the smartcard project.
test:           $(NO_TEST)

REQUIRED_PACKAGES += library/security/ocsp/libpki
REQUIRED_PACKAGES += library/security/ocsp/libpki-mozillaldap
REQUIRED_PACKAGES += library/security/ocsp/libpki-openldap
REQUIRED_PACKAGES += library/security/openssl
REQUIRED_PACKAGES += library/security/openssl/openssl-fips-140
REQUIRED_PACKAGES += shell/bash
REQUIRED_PACKAGES += shell/ksh93
REQUIRED_PACKAGES += system/core-os
REQUIRED_PACKAGES += system/library
REQUIRED_PACKAGES += system/network