gimp.spec
changeset 2380 61fcc6b08375
parent 2364 a59532821cef
child 2398 7a29461443c9
--- a/gimp.spec	Sat Apr 03 23:32:46 2004 +0000
+++ b/gimp.spec	Sat Apr 03 23:35:01 2004 +0000
@@ -85,10 +85,13 @@
 aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
 automake -a -c -f
 autoconf
-# EXTRA_CONFIGURE_OPTIONS allows passing in --disable-print
-# from Solaris spec file, since we are not currently building
-# libgimpprint
-./configure --prefix=%{_prefix} $EXTRA_CONFIGURE_OPTIONS \
+# Removing sierra driver on Solaris since it doesn't compile yet.
+%ifos solaris
+%define print_options "--disable-print"
+%else
+%define print_options ""
+%endif
+./configure --prefix=%{_prefix} \
 	    --sysconfdir=%{_sysconfdir} \
 	    --libexecdir=%{_libexecdir} \
 	    --localstatedir=/var/lib	\
@@ -96,7 +99,7 @@
 	    --enable-mp			\
 	    --enable-gtk-doc		\
 	    --enable-default-binary	   \
-		--disable-gtk-doc 
+		--disable-gtk-doc  %{print_options}
 make 
 
 %install
@@ -183,6 +186,9 @@
 %{_mandir}/man1/gimptool-%{subver}.1*
 
 %changelog
+* Sun Apr 03 2004 - [email protected]
+- Use #ifdef to set --disable-print for Solaris.
+
 * Thu Apr 01 2004 - [email protected]
 - replace tar jxf with the more solaris friendly
   bzcat piped through tar.  Now pass ACLOCAL_FLAGS into