gimp.spec
changeset 2364 a59532821cef
parent 2350 9adca2a8c84f
child 2380 61fcc6b08375
--- a/gimp.spec	Thu Apr 01 21:54:31 2004 +0000
+++ b/gimp.spec	Thu Apr 01 22:03:28 2004 +0000
@@ -75,24 +75,28 @@
 
 %prep
 %setup -q
-tar -jxf %SOURCE1
+/usr/bin/bzcat -dc %SOURCE1|tar xf -
 %patch1 -p1
 %patch2 -p1
 
 %build
 CFLAGS="$RPM_OPT_FLAGS"			\
 libtoolize --force
-aclocal -I %{_datadir}/aclocal/gnome2-macros
+aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
 automake -a -c -f
 autoconf
-./configure --prefix=%{_prefix}		\
+# EXTRA_CONFIGURE_OPTIONS allows passing in --disable-print
+# from Solaris spec file, since we are not currently building
+# libgimpprint
+./configure --prefix=%{_prefix} $EXTRA_CONFIGURE_OPTIONS \
 	    --sysconfdir=%{_sysconfdir} \
 	    --libexecdir=%{_libexecdir} \
 	    --localstatedir=/var/lib	\
 	    --mandir=%{_mandir}		\
 	    --enable-mp			\
 	    --enable-gtk-doc		\
-	    --enable-default-binary	    
+	    --enable-default-binary	   \
+		--disable-gtk-doc 
 make 
 
 %install
@@ -168,17 +172,23 @@
 
 %files devel
 
-%defattr (0755, root, root, 0755)
+%defattr (0755, root, root)
 %{_bindir}/gimptool-%{subver}
 %{_libdir}/*.so
 %dir %{_libdir}/gimp/%{subver}/modules
 
-%defattr (0644, root, root, 0755)
+%defattr (0644, root, root)
 %{_datadir}/aclocal/gimp-2.0.m4
 %{_includedir}/gimp-%{subver}/
 %{_mandir}/man1/gimptool-%{subver}.1*
 
 %changelog
+* Thu Apr 01 2004 - [email protected]
+- replace tar jxf with the more solaris friendly
+  bzcat piped through tar.  Now pass ACLOCAL_FLAGS into
+  aclocal.  Added EXTRA_CONFIGURE_OPTIONS to allow Solaris
+  to pass in --disable-print.  Fixed a few defattr lines.
+
 * Mon Mar 29 2004 - [email protected]
 - Adding gimp-l10n-po-1.0.tar.bz2 l10n content