SUNWmm-common.spec
author gheet
Thu, 22 Oct 2009 12:43:04 +0000
changeset 16837 0795431a6bb1
parent 16830 26200713fc28
child 17552 a5cc3ca42ade
permissions -rw-r--r--
2009-10-22 Ghee Teo <[email protected]> Tidied up spec file based on comments from review. * SUNWmm-common.spec:

#
# spec file for package SUNWmm-common
# - set of mm macros for building C++ binding
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner gheet
#

%include Solaris.inc

Name:                SUNWmm-common
Summary:             GNOME C++ bindings effort http://www.gtkmm.org support tools
Version:             0.8
Vendor:		     Sun Microsystems, Inc.
License:             GPL version 2
Source:              http://ftp.acc.umu.se/pub/GNOME/sources/mm-common/0.8/mm-common-%{version}.tar.bz2
SUNW_BaseDir:        %{_basedir}
SUNW_Copyright:      %{name}.copyright
BuildRoot:           %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires: SUNWbash
Requires: SUNWperl584core

%prep
%setup -q -n mm-common-%{version}

%build

CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
     CPUS=1
fi

./configure --prefix=%{_prefix}  \
            --bindir=%{_bindir} \
            --mandir=%{_mandir} 

make -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.gitignore' -exec rm {} \;

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%{_bindir}
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/aclocal
%dir %attr (0755, root, other) %{_datadir}/aclocal/*
%dir %attr (0755, root, bin) %{_datadir}/pkgconfig
%dir %attr (0755, root, bin) %{_datadir}/pkgconfig/*
%{_mandir}
%dir %attr (0755, root, other) %{_datadir}/mm-common
%dir %attr (0755, root, other) %{_datadir}/mm-common/*
%dir %attr (0755, root, other) %{_datadir}/mm-common/*/*
%dir %attr (0755, root, other) %{_datadir}/doc
%dir %attr (0755, root, other) %{_datadir}/doc/mm-common/README
%dir %attr (0755, root, other) %{_datadir}/doc/mm-common/skeletonmm
%dir %attr (0755, root, other) %{_datadir}/doc/mm-common/skeletonmm/*
%dir %attr (0755, root, other) %{_datadir}/doc/mm-common/skeletonmm/*/*
%dir %attr (0755, root, other) %{_datadir}/doc/mm-common/skeletonmm/*/*/*

%changelog
* Thu Oct 21 2009 - [email protected]
- Fixed some dependencies and also installation location.
* Fri Oct 02 2009 - [email protected]
- initial version