base-specs/sqlite.spec
author yippi
Thu, 03 Jun 2010 00:30:54 +0000
changeset 18066 1847ff0f1078
parent 17893 36619080451b
child 18099 6142061e510a
permissions -rw-r--r--
2010-06-02 Brian Cameron <[email protected]> * specs/SUNWbabl.spec, base-specs/babl.spec: Bump to 0.1.2. * patches/babl-01-solaris-build.diff: Removed, upstream. * patches/babl-01-no-pthread.diff: Add patch needed to build. * specs/SUNWgegl.spec, base-specs/gegl.spec, base-specs/gegl_64.spec: Bump to 0.1.2. * patches/gegl-01-build.diff: Rework. * patches/gegl-02-info-null.diff: Renumber from 05. * base-specs/sqlite.spec: Bump to 3.6.23. * base-specs/brltty.spec: Bump to 4.2. * base-specs/gmime.spec: Bump to 2.5.3. * base-specs/libart_lgpl.spec: Bump to 2.3.21. * base-specs/gvfs.spec: Bump to 1.6.2. * base-specs/gnome-netstatus.spec: Bump to 2.28.1. * base-specs/librsvg.spec: Bump to 2.26.3. * base-specs/gdesklets-calendar.spec: Bump to 0.74. * base-specs/pysqlite.spec: Bump to 2.6.0. * base-specs/gnome-icon-theme.spec: Bump to 2.30.3. * base-specs/libgnomeprint.spec: Bump to 2.18.7. * base-specs/libgnomeprintui.spec: Update License line to be more clear. * base-specs/libtasn1.spec: Bump to 2.7. * base-specs/notification-daemon.spec: Remove duplicate URL line.

#
# Copyright (c) 2010 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner hawklu 
# bugdb: bugzilla.freedesktop.org
#

%define OSR 12578:1.0.2
%define doc_version 3_6_23

Name:         sqlite 
License:      public domain 
Group:        System/Libraries
Version:      3.6.23
Release:      1
Distribution: Java Desktop System
Vendor:	      www.sqlite.org
Summary:      SQL database engine 
Source:       http://www.sqlite.org/%{name}-%{version}.tar.gz
Source1:      mapfile-libsqlite3
Source2:      http://www.sqlite.org/%{name}_docs_%{doc_version}.zip
Source3:      pkgIndex.tcl 


# owner:hawklu date:2008-10-10 type:bug bugster:6750518
Patch1: sqlite3-01-using-mapfile.diff

# owner:hawklu date:2010-04-01 type:bug d.o.o 15412
Patch2: sqlite3-02-using-libcurses.diff

URL:          http://www.sqlite.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on

%description
SQLite is a software library that implements a self-contained, 
serverless, zero-configuration, transactional SQL database engine. 
SQLite is the most widely deployed SQL database engine in the world. 

%package devel
Summary:      SQL database engine library
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
SQLite is a software library that implements a self-contained, 
serverless, zero-configuration, transactional SQL database engine. 
SQLite is the most widely deployed SQL database engine in the world. 

%prep
%setup -q

%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export PATH=`pwd`:$PATH

cp %{SOURCE1} .

%if %option_with_debug
 export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -I. "
%else
 export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -I. "
%endif

export LDFLAGS="%_ldflags -Bdirect"
./configure \
    --prefix=%{_prefix} \
    --libdir=%{_libdir} \
    --bindir=%{_bindir} \
    --enable-threadsafe \
    --enable-cross-thread-connections \
    --enable-load-extension \
    --enable-shared  \
    --disable-static \
    --with-tcl="/usr/lib"

make -j $CPUS


%install
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/*.la

#install pkgIndex.tcl
cp %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tcl8.4/sqlite3 
%ifarch amd64 sparcv9
rm -f $RPM_BUILD_ROOT/usr/lib/tcl8.4/sqlite3/%{_arch64}/pkgIndex.tcl
%endif

# install docs
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc
cd $RPM_BUILD_ROOT%{_datadir}/doc
unzip %{SOURCE2}
mv %{name}-%{doc_version}-docs sqlite3 


%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README TODO
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*

%changelog
* Wed Jun 02 2010 - [email protected]
- Bump to 3.6.23.
* Mon Apr 06 2010 - [email protected]
- Fix bug d.o.o 15412.
* Tue Mar 02 2010 - [email protected]
- Change license to public domain.
* Fri Jan 15 2010 - [email protected]
- initial version of the spec file.