base-specs/sqlite.spec
author chrisk
Wed, 21 Apr 2010 10:29:33 +0000
changeset 17893 36619080451b
parent 17881 1eaaaad29d9a
child 18066 1847ff0f1078
permissions -rw-r--r--
2010-04-21 Christian Kelly <[email protected]> * SUNWgnome-screensaver.spec, SUNWlibgee.spec, SUNWtgnome-tsoljdslabel.spec, SUNWgnome-ps-viewer.spec, SUNWGParted.spec, SUNWopensp.spec, base-specs/libdiscid.spec, base-specs/cairomm.spec, base-specs/libgksuui.spec, base-specs/babl.spec, base-specs/sqlite.spec, base-specs/ospm.spec, base-specs/brltty.spec, base-specs/j2re-integration.spec, base-specs/ttf-freefont.spec, base-specs/gksu.spec, base-specs/SunDesktopVersion.spec, base-specs/gnome-libs-java.spec, base-specs/docbook-style-dsssl.spec, base-specs/nimbus.spec, base-specs/ptlib.spec, base-specs/libpng10.spec, base-specs/eog-plugins.spec, base-specs/opal.spec, base-specs/libgksu.spec, base-specs/blueprint.spec, base-specs/thunderbird.spec, base-specs/pkg-config.spec, base-specs/nwam-manager.spec, base-specs/gedit-plugins.spec, base-specs/docbook-style-xsl.spec, base-specs/libexif-gtk.spec, SUNWpostrun.spec, SUNWtgnome-tsoljdsdevmgr.spec, SUNWtgnome-tsol-libs.spec, SUNWdesktop-cache.spec, SUNWgnome-dtlogin-integration.spec, closed/SUNWgnome-solaris-branding.spec, closed/SUNWflash-player-plugin.spec, SUNWgnome-base-libs.spec, SUNWjpg.spec, SUNWgnome-themes.spec, SUNWtgnome-tstripe.spec, SUNWtgnome-tsoljdsselmgr.spec, SUNWopenjade.spec, SUNWmyspell-dictionary-l10n.spec, SUNWespeak.spec: More OSR/Vendor updates.

#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner hawklu 
# bugdb: bugzilla.freedesktop.org
#

%define OSR 12578:1.0.2
%define doc_version 3_6_22

Name:         sqlite 
License:      public domain 
Group:        System/Libraries
Version:      3.6.22 
Release:      1
Distribution: Java Desktop System
Vendor:	      www.sqlite.org
Summary:      SQL database engine 
Source:       http://www.sqlite.org/%{name}-%{version}.tar.gz
Source1:      mapfile-libsqlite3
Source2:      http://www.sqlite.org/%{name}_docs_%{doc_version}.zip
Source3:      pkgIndex.tcl 


# owner:hawklu date:2008-10-10 type:bug bugster:6750518
Patch1: sqlite3-01-using-mapfile.diff

# owner:hawklu date:2010-04-01 type:bug d.o.o 15412
Patch2: sqlite3-02-using-libcurses.diff

URL:          http://www.sqlite.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on

%description
SQLite is a software library that implements a self-contained, 
serverless, zero-configuration, transactional SQL database engine. 
SQLite is the most widely deployed SQL database engine in the world. 

%package devel
Summary:      SQL database engine library
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
SQLite is a software library that implements a self-contained, 
serverless, zero-configuration, transactional SQL database engine. 
SQLite is the most widely deployed SQL database engine in the world. 

%prep
%setup -q

%patch1 -p1
%patch2 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export PATH=`pwd`:$PATH

cp %{SOURCE1} .

%if %option_with_debug
 export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -I. "
%else
 export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -I. "
%endif

export LDFLAGS="%_ldflags -Bdirect"
./configure \
    --prefix=%{_prefix} \
    --libdir=%{_libdir} \
    --bindir=%{_bindir} \
    --enable-threadsafe \
    --enable-cross-thread-connections \
    --enable-load-extension \
    --enable-shared  \
    --disable-static \
    --with-tcl="/usr/lib"

make -j $CPUS


%install
make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/*.la

#install pkgIndex.tcl
cp %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tcl8.4/sqlite3 
%ifarch amd64 sparcv9
rm -f $RPM_BUILD_ROOT/usr/lib/tcl8.4/sqlite3/%{_arch64}/pkgIndex.tcl
%endif

# install docs
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc
cd $RPM_BUILD_ROOT%{_datadir}/doc
unzip %{SOURCE2}
mv %{name}-%{doc_version}-docs sqlite3 


%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README TODO
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*

%changelog
* Mon Apr 06 2010 - [email protected]
- Fix bug d.o.o 15412
* Tue Mar 02 2010 - [email protected]
- Change license to public domain
* Fri Jan 15 2010 - [email protected]
- initial version of the spec file