specs/SUNWgnome-time-slider.spec
branchgnome-2-30-s12
changeset 23297 1185943a39b4
parent 23296 0fd6d8d846db
equal deleted inserted replaced
23296:0fd6d8d846db 23297:1185943a39b4
     1 #
       
     2 # spec file for package SUNWtime-slider
       
     3 #
       
     4 # includes module(s): time-slider
       
     5 #
       
     6 # Copyright (c) 2010, 2015 Oracle and/or its affiliates. All rights reserved.
       
     7 # This file and all modifications and additions to the pristine
       
     8 # package are under the same license as the package itself.
       
     9 #
       
    10 %define owner niall
       
    11 #
       
    12 %include Solaris.inc
       
    13 %include l10n.inc
       
    14 # NOTE: If the version is bumped the new tarball just submit the new tarball
       
    15 #       to /sgnome.
       
    16 
       
    17 %define OSR developed in the open, no OSR needed:0
       
    18 
       
    19 Name:                    SUNWgnome-time-slider
       
    20 IPS_package_name:        desktop/time-slider
       
    21 Meta(info.classification): %{classification_prefix}:Applications/Configuration and Preferences
       
    22 Summary:                 Time Slider ZFS snapshot management for GNOME
       
    23 License:                 cr_Oracle
       
    24 Version:                 0.2.102
       
    25 Source:                  http://dlc.sun.com/osol/jds/downloads/extras/time-slider/time-slider-%{version}.tar.bz2
       
    26 Source1:                 time-slider-po-sun-%{po_sun_version}.tar.bz2
       
    27 # Removing python2.6 reference from code.
       
    28 Patch1:                  time-slider-01-python27.diff
       
    29 Patch2:                  time-slider-02-zfs-python.diff
       
    30 SUNW_BaseDir:            %{_basedir}
       
    31 SUNW_Copyright:          %{name}.copyright
       
    32 BuildRoot:               %{_tmppath}/%{name}-%{version}-build
       
    33 
       
    34 %include default-depend.inc
       
    35 %include desktop-incorporation.inc
       
    36 BuildRequires:           library/python/pygtk2-27
       
    37 BuildRequires:           desktop/gksu
       
    38 Requires:                runtime/python-27
       
    39 Requires:                library/python/python-dbus-27
       
    40 Requires:                library/python/python-notify-27
       
    41 Requires:                desktop/gksu
       
    42 Requires:                gnome/zenity
       
    43 Requires:                service/gnome/desktop-cache
       
    44 Obsoletes:               SUNWzfs-auto-snapshot
       
    45 
       
    46 %package root
       
    47 Summary:                 %{summary} - / filesystem
       
    48 SUNW_BaseDir:            /
       
    49 %include default-depend.inc
       
    50 %include desktop-incorporation.inc
       
    51 
       
    52 %package l10n
       
    53 Summary:                 %{summary} - l10n files
       
    54 Requires:                %{name}
       
    55 
       
    56 %prep
       
    57 %setup -q -n time-slider-%{version}
       
    58 %patch1 -p1
       
    59 %patch2 -p1
       
    60 bzcat %SOURCE1 | tar xf -
       
    61 # replace the old translations
       
    62 cd po-sun; cp *.po LINGUAS ../po; cd ..
       
    63 
       
    64 %build
       
    65 make
       
    66 
       
    67 %install
       
    68 export PYTHON="/usr/bin/python2.7"
       
    69 rm -rf $RPM_BUILD_ROOT
       
    70 make install DESTDIR=$RPM_BUILD_ROOT
       
    71 
       
    72 mkdir -p $RPM_BUILD_ROOT/etc/security/auth_attr.d
       
    73 mkdir -p $RPM_BUILD_ROOT/etc/user_attr.d
       
    74 echo 'zfssnap::::auths=solaris.smf.manage.zfs-auto-snapshot;profiles=ZFS File System Management' > $RPM_BUILD_ROOT/etc/user_attr.d/desktop-time-slider
       
    75 echo 'solaris.smf.manage.zfs-auto-snapshot:::Manage the ZFS Automatic Snapshot Service::' > $RPM_BUILD_ROOT/etc/security/auth_attr.d/desktop-time-slider
       
    76 
       
    77 %{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
       
    78 
       
    79 %clean
       
    80 rm -rf $RPM_BUILD_ROOT
       
    81 
       
    82 %if %(test -f /usr/sadm/install/scripts/i.manifest && echo 0 || echo 1)
       
    83 %iclass manifest -f i.manifest
       
    84 %endif
       
    85 
       
    86 %post
       
    87 %restart_fmri icon-cache
       
    88 
       
    89 %actions
       
    90 user ftpuser=false gcos-field="ZFS Automatic Snapshots Reserved UID" group=daemon login-shell=/usr/bin/pfsh password=NP uid=51 username=zfssnap
       
    91 
       
    92 %files
       
    93 %defattr (-, root, bin)
       
    94 %{_bindir}/*
       
    95 %dir %attr (0755, root, bin) %{_libdir}
       
    96 %{_libdir}/time-slider-*
       
    97 %{_libdir}/time-sliderd
       
    98 %dir %attr (0755, root, bin) %{_libdir}/time-slider
       
    99 %dir %attr (0755, root, bin) %{_libdir}/time-slider/plugins/
       
   100 %dir %attr (0755, root, bin) %{_libdir}/time-slider/plugins/rsync
       
   101 %{_libdir}/time-slider/plugins/rsync/*
       
   102 %dir %attr (0755, root, bin) %{_libdir}/time-slider/plugins/zfssend
       
   103 %{_libdir}/time-slider/plugins/zfssend/*
       
   104 %dir %attr (0755, root, sys) %{_datadir}
       
   105 %dir %attr (0755, root, other) %{_datadir}/applications
       
   106 %{_datadir}/applications/*.desktop
       
   107 %dir %attr (-, root, other) %{_datadir}/icons
       
   108 %dir %attr (-, root, other) %{_datadir}/icons/hicolor
       
   109 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
       
   110 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
       
   111 %{_datadir}/icons/hicolor/16x16/apps/time-slider-setup.png
       
   112 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
       
   113 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
       
   114 %{_datadir}/icons/hicolor/24x24/apps/time-slider-setup.png
       
   115 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
       
   116 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
       
   117 %{_datadir}/icons/hicolor/32x32/apps/time-slider-setup.png
       
   118 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/36x36
       
   119 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/36x36/apps
       
   120 %{_datadir}/icons/hicolor/36x36/apps/time-slider-setup.png
       
   121 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
       
   122 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
       
   123 %{_datadir}/icons/hicolor/48x48/apps/time-slider-setup.png
       
   124 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/72x72
       
   125 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/72x72/apps
       
   126 %{_datadir}/icons/hicolor/72x72/apps/time-slider-setup.png
       
   127 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/96x96
       
   128 %dir %attr (-, root, other) %{_datadir}/icons/hicolor/96x96/apps
       
   129 %{_datadir}/icons/hicolor/96x96/apps/time-slider-setup.png
       
   130 %{_datadir}/time-slider/*
       
   131 
       
   132 %files root
       
   133 %defattr (-, root, bin)
       
   134 %attr (0755, root, sys) %dir %{_sysconfdir}
       
   135 %dir %attr (0755, root, bin) %{_sysconfdir}/dbus-1
       
   136 %dir %attr (0755, root, bin) %{_sysconfdir}/dbus-1/system.d
       
   137 %{_sysconfdir}/dbus-1/system.d/*
       
   138 %dir %attr (-, root, sys) %{_sysconfdir}/xdg
       
   139 %dir %attr (-, root, sys) %{_sysconfdir}/xdg/autostart
       
   140 %attr (-, root, sys) %{_sysconfdir}/xdg/autostart/*
       
   141 # '/etc' directory already declared above as "%{_sysconfdir}"
       
   142 %dir %attr (0755, root, sys) /etc/security
       
   143 %dir %attr (0755, root, sys) /etc/security/auth_attr.d
       
   144 %config %ips_tag(restart_fmri=svc:/system/rbac:default) %attr (0444, root, sys) /etc/security/auth_attr.d/*
       
   145 %dir %attr (0755, root, sys) /etc/user_attr.d
       
   146 %config %ips_tag(restart_fmri=svc:/system/rbac:default) %attr (0444, root, sys) /etc/user_attr.d/*
       
   147 %dir %attr (0755, root, bin) /lib
       
   148 %dir %attr (0755, root, bin) /lib/svc
       
   149 %dir %attr (0755, root, sys) /lib/svc/manifest
       
   150 %dir %attr (0755, root, sys) /lib/svc/manifest/application
       
   151 %class(manifest) %attr (0444, root, sys) /lib/svc/manifest/application/time-slider.xml
       
   152 %class(manifest) %attr (0444, root, sys) /lib/svc/manifest/application/time-slider-plugin.xml
       
   153 %dir %attr (0755, root, sys) /lib/svc/manifest/system
       
   154 %dir %attr (0755, root, sys) /lib/svc/manifest/system/filesystem
       
   155 %class(manifest) %attr (0444, root, sys) /lib/svc/manifest/system/filesystem/auto-snapshot.xml
       
   156 %attr (0555, root, bin) /lib/svc/method/time-slider
       
   157 %attr (0555, root, bin) /lib/svc/method/time-slider-plugin
       
   158 %attr (0555, root, bin) /lib/svc/method/time-slider-rsync
       
   159 
       
   160 %files l10n
       
   161 %defattr (-, root, other)
       
   162 %dir %attr (0755, root, sys) %{_datadir}
       
   163 %{_datadir}/locale/*
       
   164 
       
   165 %changelog
       
   166 * Mon Oct 15 2012 - [email protected]
       
   167 - Bump to version 0.2.102 to fix CR 7198759
       
   168 * Mon Feb 06 2012 - [email protected]
       
   169 - Bump to version 0.2.101 to fix CR 7065464.
       
   170 * Tue Jan 24 2012 - [email protected]
       
   171 - Bump to version 0.2.100 to fix CR 7064327.
       
   172 * Fri Jul 29 2011 - [email protected]
       
   173 - moved smf files from var to lib
       
   174 * Tue Aug 17 2010 - [email protected]
       
   175 - Adjust License tag to cr_Oracle for build 146a
       
   176 * Thu Jul 29 2010 - [email protected]
       
   177 - Drop upstreamed patch "-rsync-expire.diff"
       
   178 - Bump to version 0.2.97
       
   179 * Wed June 16 2010 - [email protected]
       
   180 - Add missing RBAC fragments for user_attr and auth_attr.
       
   181 - Add patch "01-rsync-expire.diff" to fix defect 16280
       
   182 * Fri June 04 2010 - [email protected]
       
   183 - Bump to version 0.2.96. Updated with new dependencies
       
   184 * Fri Feb 05 2010 - [email protected]
       
   185 - Copy LINGUAS and po files from po-sun only, not Makefile.
       
   186 * Thu Feb 04 2010 - [email protected]
       
   187 - Replace the old translations with the latest ones from po-sun.
       
   188 * Wed Dec 09 2009 - [email protected]
       
   189 - Add patch time-slider-01-python26.diff and update
       
   190   BuildRequires and Requires python deps to python26 variants.
       
   191 * Mon Nov 23 2009 - [email protected]
       
   192 - Revert to previous version (0.2.10) until removed features
       
   193   reimplemented or ARC review approved. Backs out prev. commit
       
   194 * Thu Nov 05 2009 - [email protected]
       
   195 - Bumped version to 0.2.95
       
   196 - Bumped python requirements to 2.6
       
   197 - Obsoletes SUNWzfs-auto-snapshot from 0.2.95+
       
   198 * Fri Jul 10 2009 - [email protected]
       
   199 - Bump version to 0.2.10. D.O.O# 8667, 8454 & 8685
       
   200 * Fri Apr  3 2009 - [email protected]
       
   201 - use desktop-cache instead of postrun
       
   202 * Fri Feb 20 2009 - [email protected]
       
   203 - Bump to 0.2.6 tarball to incorporate updated l10n
       
   204   from Takao Fujiwara. bugster 6807414
       
   205 - Dropped upstreamed -01-python-env.diff
       
   206 * Thu Feb 12 2009 - [email protected]
       
   207 - Add patch 01-python-env.diff to fully fix 6754650.
       
   208   Upstreamed patch. Remainder of fix already in 0.2.5 tarball
       
   209 * Thu Feb 05 2009 - [email protected]
       
   210 - Bump to 0.2.5
       
   211 - Add patch potfiles.diff to get GTK translations.
       
   212 - Add patch g11n-i18n-ui.diff to show localized date.
       
   213 * Fri Jan 09 2009 - [email protected]
       
   214 - Bump to 0.2.3
       
   215 * Mon Dec 17 2008 - [email protected]
       
   216 - Bump to 0.2.2
       
   217 * Mon Oct 20 2008 - [email protected]
       
   218 - Bump to 0.1.2 with .po files. Add l10n packages.
       
   219 * Fri Oct 10 2008 - [email protected]
       
   220 - disable auto SMF enabelment in post install
       
   221 * Wed Oct 08 2008 - [email protected]
       
   222 - Bump to 0.1.1 Drop upstreamed g11n-i18n.diff
       
   223 * Thu Oct 02 2008 - [email protected]
       
   224 - Add time-slider-01-g11n-i18n.diff
       
   225 * Wed Sep 18 2008 - [email protected]
       
   226 - Initial spec file created.
       
   227 
       
   228 
       
   229