19623766 hiera-19 package not installed if ruby-19 not installed
authorKristina Tripp <Kristina.Tripp@oracle.com>
Thu, 18 Sep 2014 15:01:38 -0600
changeset 2097 fad389ea20c7
parent 2096 ea57cc1059bf
child 2098 a5eead2dcc0b
19623766 hiera-19 package not installed if ruby-19 not installed 19646558 puppet-19 package not installed if ruby-19 not installed 19646677 facter-19 package not installed if ruby-19 not installed
components/ruby/facter/facter-GENFRAG.p5m
components/ruby/facter/facter-RUBYVER.p5m
components/ruby/hiera/hiera-GENFRAG.p5m
components/ruby/hiera/hiera-RUBYVER.p5m
components/ruby/puppet/puppet-GENFRAG.p5m
components/ruby/puppet/puppet-RUBYVER.p5m
--- a/components/ruby/facter/facter-GENFRAG.p5m	Thu Sep 18 09:47:48 2014 -0700
+++ b/components/ruby/facter/facter-GENFRAG.p5m	Thu Sep 18 15:01:38 2014 -0600
@@ -30,3 +30,6 @@
 
 license facter.license license="Apache v2.0"
 
+# force dependency on ruby runtime package to ensure at least one version
+# of ruby is installed on the system
+depend type=require fmri=pkg:/runtime/ruby
--- a/components/ruby/facter/facter-RUBYVER.p5m	Thu Sep 18 09:47:48 2014 -0700
+++ b/components/ruby/facter/facter-RUBYVER.p5m	Thu Sep 18 15:01:38 2014 -0600
@@ -1174,4 +1174,4 @@
 
 # force a dependency on the facter package
 depend type=require \
-    fmri=system/management/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    fmri=pkg:/system/management/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
--- a/components/ruby/hiera/hiera-GENFRAG.p5m	Thu Sep 18 09:47:48 2014 -0700
+++ b/components/ruby/hiera/hiera-GENFRAG.p5m	Thu Sep 18 15:01:38 2014 -0600
@@ -35,3 +35,6 @@
 dir  path=var/lib/hiera
 license hiera.license license="Apache v2.0"
 
+# force dependency on ruby runtime package to ensure at least one version
+# of ruby is installed on the system
+depend type=require fmri=pkg:/runtime/ruby
--- a/components/ruby/hiera/hiera-RUBYVER.p5m	Thu Sep 18 09:47:48 2014 -0700
+++ b/components/ruby/hiera/hiera-RUBYVER.p5m	Thu Sep 18 15:01:38 2014 -0600
@@ -213,4 +213,4 @@
 
 # force a dependency on the hiera package
 depend type=require \
-    fmri=library/ruby/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    fmri=pkg:/library/ruby/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
--- a/components/ruby/puppet/puppet-GENFRAG.p5m	Thu Sep 18 09:47:48 2014 -0700
+++ b/components/ruby/puppet/puppet-GENFRAG.p5m	Thu Sep 18 15:01:38 2014 -0600
@@ -194,3 +194,7 @@
 user username=puppet ftpuser=false gcos-field="Puppet Admin" group=puppet \
     home-dir=/etc/puppet login-shell=/bin/false uid=40
 license puppet.license license="Apache v2.0"
+
+# force dependency on ruby runtime package to ensure at least one version
+# of ruby is installed on the system
+depend type=require fmri=pkg:/runtime/ruby
--- a/components/ruby/puppet/puppet-RUBYVER.p5m	Thu Sep 18 09:47:48 2014 -0700
+++ b/components/ruby/puppet/puppet-RUBYVER.p5m	Thu Sep 18 15:01:38 2014 -0600
@@ -1103,9 +1103,9 @@
 license puppet.license license="Apache v2.0"
 
 # Puppet Dependencies
-depend type=require fmri=system/management/facter-$(RUBYV)
-depend type=require fmri=library/ruby/hiera-$(RUBYV)
+depend type=require fmri=pkg:/system/management/facter-$(RUBYV)
+depend type=require fmri=pkg:/library/ruby/hiera-$(RUBYV)
 
 # force a dependency on the puppet package
 depend type=require \
-    fmri=system/management/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)
+    fmri=pkg:/system/management/[email protected]$(IPS_COMPONENT_VERSION),$(BUILD_VERSION)